Project

General

Profile

action #10940

openqa.suse.de: repeating error in log "Query returned more than one row"

Added by okurz over 6 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2016-02-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

many errors reported on openqa.suse.de:

Feb 26 14:14:29 openqa openqa[3421]: DBIx::Class::Storage::DBI::select_single(): Query returned more than one row.  SQL that returns multiple rows is DEPRECATED for ->find and ->single at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/API/V1.pm line 85
Feb 26 14:14:30 openqa openqa[3421]: DBIx::Class::Storage::DBI::select_single(): Query returned more than one row.  SQL that returns multiple rows is DEPRECATED for ->find and ->single at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/API/V1.pm line 85
...

steps to reproduce

  • login to openqa.suse.de
  • journalctl -f -u openqa-webui
  • observe error

further notes

also other warnings

Feb 26 14:15:30 openqa openqa[3421]: Use of uninitialized value $md5 in substr at
Feb 26 14:15:30 openqa openqa[3421]: /usr/share/openqa/script/../lib/OpenQA/Utils.pm line 181 (#1)
Feb 26 14:15:30 openqa openqa[3421]: (W uninitialized) An undefined value was used as if it were already
Feb 26 14:15:30 openqa openqa[3421]: defined.  It was interpreted as a "" or a 0, but maybe it was a mistake.
Feb 26 14:15:30 openqa openqa[3421]: To suppress this warning assign a defined value to your variables.
Feb 26 14:15:30 openqa openqa[3421]: To help you figure out what was undefined, perl will try to tell you
Feb 26 14:15:30 openqa openqa[3421]: the name of the variable (if any) that was undefined.  In some cases
Feb 26 14:15:30 openqa openqa[3421]: it cannot do this, so it also tells you what operation you used the
Feb 26 14:15:30 openqa openqa[3421]: undefined value in.  Note, however, that perl optimizes your program
Feb 26 14:15:30 openqa openqa[3421]: anid the operation displayed in the warning may not necessarily appear
Feb 26 14:15:30 openqa openqa[3421]: literally in your program.  For example, "that $foo" is usually
Feb 26 14:15:30 openqa openqa[3421]: optimized into "that " . $foo, and the warning will refer to the
Feb 26 14:15:30 openqa openqa[3421]: concatenation (.) operator, even though there is no . in
Feb 26 14:15:30 openqa openqa[3421]: your program.
Feb 26 14:15:30 openqa openqa[3421]: Use of uninitialized value $md5 in substr at
Feb 26 14:15:30 openqa openqa[3421]: /usr/share/openqa/script/../lib/OpenQA/Utils.pm line 182 (#1)
Feb 26 14:15:30 openqa openqa[3421]: substr outside of string at /usr/share/openqa/script/../lib/OpenQA/Utils.pm
Feb 26 14:15:30 openqa openqa[3421]: line 182 (#2)
Feb 26 14:15:30 openqa openqa[3421]: (W substr)(F) You tried to reference a substr() that pointed outside of
Feb 26 14:15:30 openqa openqa[3421]: a string.  That is, the absolute value of the offset was larger than the
Feb 26 14:15:30 openqa openqa[3421]: length of the string.  See "substr" in perlfunc.  This warning is fatal if
Feb 26 14:15:30 openqa openqa[3421]: substr is used in an lvalue context (as the left hand side of an
Feb 26 14:15:30 openqa openqa[3421]: assignment or as a subroutine argument for example).
Feb 26 14:15:30 openqa openqa[3421]: Use of uninitialized value $md5 in concatenation (.) or string at
Feb 26 14:15:30 openqa openqa[3421]: /usr/share/openqa/script/../lib/OpenQA/Utils.pm line 183 (#1)
Feb 26 14:15:30 openqa openqa[3421]: Use of uninitialized value in concatenation (.) or string at
Feb 26 14:15:30 openqa openqa[3421]: /usr/share/openqa/script/../lib/OpenQA/Schema/Result/JobModules.pm line 266 (#1)
Feb 26 14:15:30 openqa openqa[3421]: Use of uninitialized value in concatenation (.) or string at
Feb 26 14:15:30 openqa openqa[3421]: /usr/share/openqa/script/../lib/OpenQA/Schema/Result/JobModules.pm line 267 (#1

Related issues

Related to openQA Tests - action #20378: [tools]Too many 502 on openqaResolved2017-07-18

History

#1 Updated by okurz over 6 years ago

  • Description updated (diff)
  • Priority changed from Normal to Immediate

Current problem I am having: access to https://openqa.suse.de/tests/overview?distri=sle&version=12-SP2&build=1204&groupid=25 does not work, times out with

Bad Gateway!

The proxy server received an invalid response from an upstream server.

The proxy server could not handle the request GET /tests/overview.

Reason: Error reading from remote server

If you think this is a server error, please contact the webmaster.
Error 502
openqa.suse.de
Apache/2.4.10 (Linux/SUSE) 

#2 Updated by oholecek over 6 years ago

I observed the warning about multiple returned rows already few weeks back, so I don't think timeout problems is because of it.

#3 Updated by okurz over 6 years ago

  • Priority changed from Immediate to High

ok, so this error might not be that important to follow but the other reported problems still could have an impact?

#4 Updated by okurz over 6 years ago

  • Priority changed from High to Normal

I think this has less impact. I opened another ticket for the current performance regression issue instead: #10960

#5 Updated by coolo about 6 years ago

Coming back to the original issue:

We have at the moment two jobs which have worker_id 246 - as such $worker->job gives the warning in #0. No idea how this happened.

id | slug | priority | worker_id | test

436465 | | 60 | 246 | slenkins-twopence-nis-server | | 3 | 2016-06-07 18:13:37 | | 2016-06-07 17:39:12 | 2016-06-07 17:39:12 | running | none | | | | 31
436557 | | 60 | 246 | slenkins-tests-vsftpd-server | | 3 | 2016-06-07 18:19:44 | | 2016-06-07 18:08:24 | 2016-06-07 18:20:00 | running | none | {} | 00436557-sle-12-SP2-Server-DVD-x86_64-Build1590-slenkins-tests-vsftpd-server | qemu | 31

#6 Updated by coolo about 6 years ago

it's really puzzling as worker::register resets the job

#7 Updated by okurz over 5 years ago

  • Category set to Concrete Bugs
  • Priority changed from Normal to Low

#8 Updated by EDiGiacinto almost 5 years ago

Caused most probably by race conditions in job_grab, should now be solved by #20378

#9 Updated by EDiGiacinto almost 5 years ago

#10 Updated by EDiGiacinto almost 5 years ago

  • Status changed from New to In Progress
  • Assignee set to EDiGiacinto

Closing this bug since it might be related to #20378 which is now solved. Please re-open if problem still persist - in case it is persisting and the bug had attachments (such logs, screens, ecc.) please provide new ones.

#11 Updated by EDiGiacinto almost 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF