Project

General

Profile

action #108998

openqa_install+publish fails in start_test

Added by cdywan 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
Start date:
2022-03-31
Due date:
% Done:

0%

Estimated time:

Description

Observation

https://openqa.opensuse.org/tests/2264533#step/start_test/19

Acceptance criteria

  • AC1: The start_test module clones a job without 503 errors

Suggestions


Related issues

Related to openQA Infrastructure - action #109052: openqa_install+publish fails in dashboardResolved2022-02-16

Copied from openQA Infrastructure - action #106919: openqa_install+publish fails in start_test size:MResolved2022-02-162022-03-03

History

#1 Updated by cdywan 3 months ago

  • Copied from action #106919: openqa_install+publish fails in start_test size:M added

#2 Updated by okurz 3 months ago

  • Related to action #109052: openqa_install+publish fails in dashboard added

#3 Updated by okurz 3 months ago

  • Status changed from New to Blocked
  • Assignee set to jbaier_cz

#4 Updated by jbaier_cz 3 months ago

A quick look to the logs revealed:

[  599.054168] openqa-gru[7528]: [info] Caching "https://raw.githubusercontent.com/twbs/bootstrap/v4.6.1/scss/bootstrap.scss" to "/usr/share/openqa/script/../assets/cache/raw.githubusercontent.com/twbs/bootstrap/v4.6.1/scss/bootstrap.scss".
[  599.185807] openqa-gru[7528]: mkdir /usr/share/openqa/script/../assets/cache/raw.githubusercontent.com/twbs/bootstrap/v4.6.1: Permission denied at /usr/lib/perl5/vendor_perl/5.34.0/Mojo/File.pm line 84.
[  599.223390] worker[5055]: [info] Registering with openQA localhost
[  599.224310] worker[5055]: [warn] Failed to register at localhost - 503 response: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
[  599.225545] worker[5055]: <html><head>
[  599.226019] worker[5055]: <title>503 Service Unavailable</title>
[  599.226718] worker[5055]: </head><body>
[  599.227219] worker[5055]: <h1>Service Unavailable</h1>
[  599.227826] worker[5055]: <p>The server is temporarily unable to service your
[  599.228642] worker[5055]: request due to maintenance downtime or capacity
[  599.229389] worker[5055]: problems. Please try again later.</p>
[  599.230065] worker[5055]: <p>Additionally, a 503 Service Unavailable
[  599.230908] worker[5055]: error was encountered while trying to use an ErrorDocument to handle the request.</p>
[  599.232018] worker[5055]: <hr>
[  599.232489] worker[5055]: <address>Apache Server at localhost Port 80</address>
[  599.233293] worker[5055]: </body></html>
[  599.233777] worker[5055]:  - trying again in 10 seconds

#5 Updated by jbaier_cz 3 months ago

  • Status changed from Blocked to In Progress
  • Start date changed from 2022-02-16 to 2022-03-31

#6 Updated by mkittler 3 months ago

  • Status changed from In Progress to Resolved

That error was caused by our migration to a new bootstrap version which wasn't conducted correctly in the first place. I've got the very same error locally when trying to use the broken rpm.

Also available in: Atom PDF