Project

General

Profile

action #106919

openqa_install+publish fails in start_test size:M

Added by cdywan 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
Start date:
2022-02-16
Due date:
2022-03-03
% Done:

0%

Estimated time:

Description

Observation

https://openqa.opensuse.org/tests/2191508

Acceptance criteria

  • AC1: The start_test module finishes without timing out

Suggestions

  • Reveal download progress in logs

Related issues

Copied to openQA Project - coordination #106922: [epic][sporadic] openqa_from_git fails in dashboard due to ensure_unlocked_desktop not expecting password entry screen in case of locked desktop auto_review:"match=desktop-runner,screenlock timed out.*":retryBlocked2022-02-16

Copied to openQA Infrastructure - action #108998: openqa_install+publish fails in start_testResolved2022-03-31

History

#1 Updated by cdywan 4 months ago

  • Copied to coordination #106922: [epic][sporadic] openqa_from_git fails in dashboard due to ensure_unlocked_desktop not expecting password entry screen in case of locked desktop auto_review:"match=desktop-runner,screenlock timed out.*":retry added

#2 Updated by okurz 4 months ago

  • Priority changed from Normal to Urgent
  • Target version set to Ready

Please add such CI regressions immediately to our backlog especially when not fixing such issues would mean repeatedly receiving reminder emails.

#3 Updated by mkittler 4 months ago

  • Assignee set to mkittler

Looks like it was just too slow (downloading the TW snapshot iso from within the SUT). The default timeout of 90 seconds doesn't seem to be very high for downloading a possibly big file. I'd also add --show-progress to see what's going on.

#4 Updated by mkittler 4 months ago

  • Status changed from New to In Progress

So maybe this helps: https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/80

I still need to do a local verification run. (Takes a while as I need to download the assets here as well.)

#5 Updated by openqa_review 4 months ago

  • Due date set to 2022-03-03

Setting due date based on mean cycle time of SUSE QE Tools

#6 Updated by cdywan 4 months ago

  • Subject changed from openqa_install+publish fails in start_test to openqa_install+publish fails in start_test size:M
  • Description updated (diff)

#7 Updated by mkittler 4 months ago

  • Status changed from In Progress to Feedback
  • Priority changed from Urgent to High

Let's see whether extending the timeout by 30 seconds is enough.

#8 Updated by mkittler 4 months ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved

The jobs are passing on o3 so I'm resolving the ticket.

#9 Updated by cdywan 3 months ago

  • Copied to action #108998: openqa_install+publish fails in start_test added

Also available in: Atom PDF