Project

General

Profile

action #106963

wicked: debug packages missing on o3

Added by dimstar 12 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-02-17
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-wicked_basic_sut@64bit fails in
before_test

2022-02-17 01:59:44 susetest(3150) [zypp-core] Exception.cc(log):186 - Can't provide ./x86_64/wicked-debugsource-0.6.68-2.1.x86_64.rpm

Since https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/14263, the test tries to install wicked-debugsource. But the sync to O3 was not configured to also include the needed packages; o3 only syncs part of the debug repo due to space concerns

Test suite description

Include basic sanity checks of wicked network framework
Maintainer: qa-c@suse.de

Reproducible

Fails since (at least) Build 20220215

Expected result

Last good: 20220214 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dimstar 12 months ago

  • Subject changed from test fails in before_test to wicked: debug packages missing on o3

#2 Updated by maritawerner 12 months ago

  • Tags set to qac

#3 Updated by cfconrad 12 months ago

Investigation

The test install wicked-debuginfo only if it is availble, like

zypper search wicked-debuginfo && zypper -n in --force -y --force-resolution wicked-debuginfo

The problem is that wicked-debugsource is recommend and it is installed, too.
But this package isn't available.

I will check if a --no-recommends avoid this error. And from test POV it's not a problem, as we do the same with the debugsource later on.

#4 Updated by cfconrad 12 months ago

hm unfortunately this doesn't work neither, investigate...

# zypper search wicked-debuginfo; echo 88x~r-$?-
Loading repository data...
Reading installed packages...

S | Name             | Summary                              | Type
--+------------------+--------------------------------------+--------
  | wicked-debuginfo | Debug information for package wicked | package
88x~r-0-
# zypper -n in --force -y --force-resolution --no-recommends wicked-debuginfo | cat; ( exit ${PIPESTATUS[0]} ); echo WpKJN-$?-
Loading repository data...
Reading installed packages...
Forcing installation of 'wicked-debuginfo-0.6.68-2.1.x86_64' from repository 'OSS_DEBUGINFO'.
Resolving package dependencies...

The following NEW package is going to be installed:
  wicked-debuginfo

1 new package to install.
Overall download size: 2.1 MiB. Already cached: 0 B. After the operation, additional 5.2 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): y
Retrieving package wicked-debuginfo-0.6.68-2.1.x86_64 (1/1),   2.1 MiB (  5.2 MiB unpacked)
Retrieving: wicked-debuginfo-0.6.68-2.1.x86_64.rpm [not found]
File './x86_64/wicked-debuginfo-0.6.68-2.1.x86_64.rpm' not found on medium 'http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20220215-debuginfo'
Abort, retry, ignore? [a/r/i/...? shows all options] (a): a
Problem occurred during or after installation or removal of packages:
Installation has been aborted as directed.
Please see the above error message for a hint.
WpKJN-8-

#5 Updated by cfconrad 12 months ago

But the sync to O3 was not configured to also include the needed packages; o3 only syncs part of the debug repo due to space concerns

Ok I just overread this!

#6 Updated by cfconrad 12 months ago

Discussed with dimstar in chat, we think adding wicked-debug* to o3 repos should be cheap enough to do so.

#8 Updated by jlausuch 12 months ago

  • Status changed from New to In Progress
  • Assignee set to cfconrad

#9 Updated by cfconrad 12 months ago

The SLE-12-SP4 error https://openqa.suse.de/tests/8183306#step/before_test/159 is different, as this cannot install systemd-coredump I guess systemd is just to old. I would simply exclude with is_sle('<12-SP5')

#11 Updated by cfconrad 12 months ago

#12 Updated by dimstar 2 months ago

  • Status changed from In Progress to Resolved

cfconrad wrote:

https://github.com/os-autoinst/openqa-trigger-from-obs/pull/154 this should enable debug sync for o3

Had been merged quite a while ago and the tests have been reliably passing

Also available in: Atom PDF