Project

General

Profile

Actions

action #106957

closed

[tools][tw][aarch64][QEMUTPM][tpm2.0] on some O3 arm workers, swtpm 2.0 device can't be created [or created failed]

Added by rfan1 over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2022-02-17
Due date:
% Done:

0%

Estimated time:

Description

Hello tool team experts, can I ask for your kindly help to check the issue below?
BTW, the failure is not seen on all arm workers
The below one can pass:
https://openqa.opensuse.org/tests/2191037

Observation

With job setting below:
QEMUTPM: 1
QEMUTPM_VER: 2.0

The tests failed on some arm workers, with different error messages:

https://openqa.opensuse.org/tests/2191101
Reason: backend died: runcmd 'swtpm socket --tpmstate dir=/tmp/mytpm1 --ctrl type=unixio,path=/tmp/mytpm1/swtpm-sock --log level=20 -d --tpm2' failed with exit code 1 at /usr/lib/os-autoinst/osutils.pm line 109.

https://openqa.opensuse.org/tests/2193108 [seems the backend does not create the swtpm socket at all]
[2022-02-17T02:09:04.271 UTC] [warn] !!! : qemu-system-aarch64: -chardev socket,id=chrtpm,path=/tmp/mytpm1/swtpm-sock: Failed to connect socket /tmp/mytpm1/swtpm-sock: No such file or directory

Steps to reproduce

Job settings:
QEMUTPM: 1
QEMUTPM_VER: 2.0

Workaround

Re-trigger the job and some of the workers can pass the tests

@cdywan, just assigned the ticket to you since you helped much on this before.


Related issues 1 (0 open1 closed)

Related to openQA Project - action #107155: [tools][tw][sle][QEMUTPM][tpm2.0] swtpm devices need to be clear once test doneResolvedXiaojing_liu2022-02-21

Actions
Actions

Also available in: Atom PDF