Project

General

Profile

Actions

action #102662

closed

Fix collecting y2logs when system error occurs during installation

Added by oorlov over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
2021-11-18
Due date:
% Done:

0%

Estimated time:

Description

The following job failed in Y Staging job group due to system error during installation, but y2logs are failed to collect. Please see the image attached to see how the error screen looks.

Steps to reproduce on BuildY31.1:

  1. Start installation with YDEBUG=1 and regurl=;
  2. Proceed through installer wizard to registration step;
  3. Fill in valid reg code and press "Next" button;
  4. Focus on the installer.

Actual result: The error occurs.

Failed Job: https://openqa.suse.de/tests/7697867#step/addon_products_sle/23

Task

  1. Fix y2logs to collect them after the system crashes due to system error (oorlov checked it manually, it is possible in the same way, as usually: change tty and collect logs);
  2. Provide VRs.

NOTE: As the iso may be removed from openQA when we'll pick up the ticket to work on and new builds may not contain the error, it may be not so easy to check if the fix works. The BuildY31.1 iso with the error can be downloaded here: http://oorlov-vm.qa.suse.de:7777/


Files

download.png (19.5 KB) download.png oorlov, 2021-11-18 16:28

Related issues 1 (0 open1 closed)

Related to qe-yam - coordination #105073: [Epic] Improve logging in openQARejected2022-01-19

Actions
Actions #1

Updated by oorlov over 2 years ago

  • Description updated (diff)
Actions #2

Updated by oorlov over 2 years ago

  • Tags deleted (qe-yast-refinement)
  • Status changed from New to Workable
Actions #3

Updated by geor over 2 years ago

  • Assignee set to geor
Actions #4

Updated by JERiveraMoya over 2 years ago

  • Status changed from Workable to In Progress
Actions #5

Updated by geor over 2 years ago

This is a run where fail occurs (with SLE-15-SP4-Online-x86_64-BuildY.31.1-Media1.iso on my openqa instance)

Actions #7

Updated by JRivrain over 2 years ago

Actions #8

Updated by geor about 2 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF