action #10136

"reboot now" can not be detected, potentially skipped

Added by okurz over 4 years ago. Updated about 4 years ago.

Status:ResolvedStart date:07/01/2016
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Bugs in existing tests
Target version:openQA Project - Milestone 1
Difficulty:
Duration:

Description

observation

e.g. "RAID6: test does not wait for installation to finish"
https://openqa.suse.de/tests/175725

also observed in http://openqa.suse.de/tests/188411

expected result

installer dialog to abort the reboot should have been found as in
https://openqa.suse.de/tests/187514/modules/livecdreboot/steps/1

problem

H1. product issue: reboot dialog is skipped
H2. reboot is happening to fast to catch (even to fast to be catched in video?)
H3. somehow "OK" button is pressed for immediate reboot before it can show up on screen
H4. maybe it is something about timing taking much longer on RAID6 or so but I can not easily understand what's wrong here.

suggestion

try to reproduce manually


Related issues

Related to openQA Project - action #10460: *Huge* gaps in assert_screen Resolved 28/01/2016
Duplicated by openQA Tests - action #10424: "reboot now" can not be detected, potentially skipped Closed 26/01/2016

History

#1 Updated by RBrownSUSE about 4 years ago

  • Target version deleted (156)

#2 Updated by RBrownSUSE about 4 years ago

  • Target version set to 162

#3 Updated by dgutu about 4 years ago

  • Assignee set to dgutu

#4 Updated by dgutu about 4 years ago

As soon as I can see this test is not failing on the latest build:
https://openqa.suse.de/tests/186980/modules/livecdreboot/steps/3

On mine openQA instance the test is fully green.

#5 Updated by dgutu about 4 years ago

  • % Done changed from 0 to 100

From today's build - https://openqa.suse.de/tests/188604
Everything is fine, can we close it?

#6 Updated by okurz about 4 years ago

  • Duplicated by action #10424: "reboot now" can not be detected, potentially skipped added

#7 Updated by okurz about 4 years ago

  • Subject changed from RAID6: test does not wait for installation to finish to "reboot now" can not be detected, potentially skipped
  • Description updated (diff)
  • % Done changed from 100 to 0

@dgutu it seems this issue is hard to reproduce and flaky, too. Today I created #10424 which I am closing as a duplicate based on this one and merging observations into this ticket. I don't see this is solved as of today.

#8 Updated by okurz about 4 years ago

#9 Updated by okurz about 4 years ago

  • Status changed from New to Feedback

I could reproce problems within "livecdreboot" on my openQA installation on cloud.suse.de read "slow IO" and came up with
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/987
So I suggest to merge this and then observe if it helps with others.

#10 Updated by coolo about 4 years ago

From the original log file:


no match 1793
MATCH(rebootnow-20131217:0.00)
MATCH(rebootnow-20141204:0.00)
MATCH(rebootnow-20150409:0.00)
MATCH(rebootnow-390x-20150709:0.44)
no match 1770

So it's the same problem as reported in #10460

#11 Updated by coolo about 4 years ago

  • Status changed from Feedback to Resolved
  • Assignee deleted (dgutu)

dup of 10460

#12 Updated by okurz about 4 years ago

  • Target version changed from 162 to Milestone 1

Also available in: Atom PDF