Project

General

Profile

action #101030

Typing problems on aarch64

Added by dzedro about 2 months ago. Updated 20 days ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-10-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

I guess since this week there started to be failures on aarch64 due to mistyped commands.

https://openqa.suse.de/tests/7421722#step/textinfo/15
https://openqa.suse.de/tests/7412494#step/zypper_lifecycle/32
https://openqa.suse.de/tests/7411270#step/zypper_in/9
https://openqa.suse.de/tests/7410463#step/force_scheduled_tasks/18
https://openqa.suse.de/tests/7409878#step/textinfo/10

openQA test in scenario sle-15-Server-DVD-Updates-aarch64-qam-minimal+base@aarch64-virtio fails in
textinfo

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml.

Reproducible

Fails since (at least) Build 20211015-1 (current job)

Expected result

Last good: 20211014-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - coordination #101048: [epic] Investigate and fix higher instability of openqaworker-arm-4/5 vs. arm-1/2/3Workable2021-10-15

History

#1 Updated by dzedro about 2 months ago

  • Project changed from openQA Tests to openQA Project
  • Category deleted (Bugs in existing tests)

#2 Updated by dzedro about 2 months ago

  • Subject changed from Typing problems problems on aarch64 to Typing problems on aarch64

#3 Updated by okurz about 2 months ago

  • Related to coordination #101048: [epic] Investigate and fix higher instability of openqaworker-arm-4/5 vs. arm-1/2/3 added

#4 Updated by okurz about 2 months ago

  • Category set to Concrete Bugs
  • Priority changed from Normal to Urgent
  • Target version set to Ready

Might be related to #101048

#5 Updated by cdywan about 2 months ago

Checking https://openqa.suse.de/tests/7421722#step/textinfo/15 I see this:

# Test died: command 'rm textinfo' failed at /usr/lib/os-autoinst/testapi.pm line 950.
    testapi::_handle_script_run_ret(1, "rm textinfo", "quiet", undef, "timeout", 90, "fail_message", "") called at /usr/lib/os-autoinst/testapi.pm line 988

So it seems the timeout of 90 seconds was exceeded i.e. assert_script_run('rm textinfo');. The same applies to https://openqa.suse.de/tests/7411270#step/zypper_in/9 (testapi::assert_script_run("rpm -e x3270")).


https://openqa.suse.de/tests/7410463#step/force_scheduled_tasks/18 apparently stops here:

force_scheduled_tasks::settle_load() called at sle/tests/console/force_scheduled_tasks.pm line 67

The last screenshot shows -bash: /deev/ttyAMA0: No such file or directory. It looks like there's an e too many.

#6 Updated by dzedro about 2 months ago

cdywan wrote:

Checking https://openqa.suse.de/tests/7421722#step/textinfo/15 I see this:

# Test died: command 'rm textinfo' failed at /usr/lib/os-autoinst/testapi.pm line 950.
  testapi::_handle_script_run_ret(1, "rm textinfo", "quiet", undef, "timeout", 90, "fail_message", "") called at /usr/lib/os-autoinst/testapi.pm line 988

So it seems the timeout of 90 seconds was exceeded i.e. assert_script_run('rm textinfo');. The same applies to https://openqa.suse.de/tests/7411270#step/zypper_in/9 (testapi::assert_script_run("rpm -e x3270")).

Of course timeout exceeded when command was not typed properly -> mistyped.
Yes, looks like failures are happening on openqaworker-arm-4/5

#7 Updated by cdywan about 2 months ago

dzedro wrote:

cdywan wrote:

Checking https://openqa.suse.de/tests/7421722#step/textinfo/15 I see this:

# Test died: command 'rm textinfo' failed at /usr/lib/os-autoinst/testapi.pm line 950.
    testapi::_handle_script_run_ret(1, "rm textinfo", "quiet", undef, "timeout", 90, "fail_message", "") called at /usr/lib/os-autoinst/testapi.pm line 988

So it seems the timeout of 90 seconds was exceeded i.e. assert_script_run('rm textinfo');. The same applies to https://openqa.suse.de/tests/7411270#step/zypper_in/9 (testapi::assert_script_run("rpm -e x3270")).

Of course timeout exceeded when command was not typed properly -> mistyped.
Yes, looks like failures are happening on openqaworker-arm-4/5

Right, it says rrpm and textinffo respectively in the needles. It seems a bit odd to me, though, that it times out rather than an error from the zypper or bash. So I guess it times out before the command is finished.

#8 Updated by nicksinger about 2 months ago

I'd rather try to solve poo#101048 to see if it eases the situation here too

#9 Updated by okurz about 2 months ago

  • Status changed from New to Blocked
  • Assignee set to okurz

#11 Updated by okurz 20 days ago

  • Status changed from Blocked to Resolved

We have identified the situation as caused by instabilities on openqaworker-arm-4/5 and have disabled the machine since then from production. Work to investigate the root cause and bring back the machine is done in #101048

Also available in: Atom PDF