Project

General

Profile

action #97280

[kernel-qa] test fails in bpf_prog05 and ptrace10

Added by mgrifalconi 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-08-20
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-ltp_syscalls_pre12sp4@64bit fails in
bpf_prog05

Test suite description

A large collection of tests for individual system calls. This is generally considered to be the most important test suite within the LTP. The IPC tests have been filtered out from the syscalls runtest file. They are ran as part of the syscalls_ipc test case.

disabled fanotify07 due kernel pollution

Reproducible

Fails since (at least) Build 20210820-1

Expected result

Last good: 20210819-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#2 Updated by pvorel 5 months ago

It can be a test bug on old kernels or kernel fix not being backported.

bpf_prog05 requires kernel commits from 4.16 (f6b1b3bf0d5f, 468f6eafa6c4) and 5.11 (e88b2c6e5a4d, 9b00f1b78809). ptrace10 commit from 4.19 (bd14406b78e6). SLE12-SP2 runs 4.4.121.

Fixes for bpf_prog05 has been backported to SLE12-SP4-LTSS, the old versions has been left.

#3 Updated by MDoucha 5 months ago

  • Status changed from New to Resolved
  • Assignee set to MDoucha

This is caused by a new check which queries Bugzilla and only whitelists the failures if the bug is still open. I need to add BUGZILLA_URL to the medium to whitelist those failures again. I've also cloned the job with BUGZILLA_URL manually.

#4 Updated by mgrifalconi 5 months ago

  • Status changed from Resolved to New

Reopening since BUGZILLA_URL does not fix all problems. Examples:
https://openqa.suse.de/tests/6904969#
https://openqa.suse.de/tests/6904602#step/bpf_prog05/12

#6 Updated by MDoucha 4 months ago

  • Tags set to ltp
  • Status changed from New to Resolved

ptrace10 failure has been whitelisted through ltp_known_issues.yaml since Labs have decided to leave the kernel bug unfixed in LTSS kernels. bpf_prog05 test bug has been fixed in LTP upstream. Closing as resolved.

Also available in: Atom PDF