Project

General

Profile

Actions

action #95323

closed

coordination #127031: [saga][epic] openQA for SUSE customers

coordination #80150: [epic] Scale out openQA: Easier openQA setup

coordination #93609: [epic] openqa-bootstrap support on Leap 15.3

openqa-bootstrap support on current version of Leap - automatic test size:S

Added by okurz almost 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2021-07-09
Due date:
% Done:

0%

Estimated time:

Description

Motivation

See parent #93609

Acceptance criteria

  • AC1: Automatic test of openqa-bootstrap on Leap exists and passes

Suggestions

Actions #1

Updated by okurz over 2 years ago

  • Subject changed from openqa-bootstrap support on Leap 15.3 - automatic test to openqa-bootstrap support on current version of Leap - automatic test
  • Description updated (diff)
  • Target version changed from future to Ready
Actions #2

Updated by okurz over 2 years ago

  • Subject changed from openqa-bootstrap support on current version of Leap - automatic test to openqa-bootstrap support on current version of Leap - automatic test size:S
  • Description updated (diff)
  • Status changed from New to Workable
Actions #3

Updated by mkittler over 2 years ago

  • Assignee set to mkittler
Actions #4

Updated by mkittler over 2 years ago

  • Status changed from Workable to In Progress

Try out the openqa-bootstrap test scenario once against a current version of Leap, e.g. 15.3 at time of writing for maintenance tests, or 15.4 for product validation tests, e.g. using openqa-clone-job

That's what I ended up with: manual download of Leap 15.4 qcow image + cloning TW's openqa_bootstrap test modifying vars to use the Leap qcow

cd /hdd/openqa-devel/openqa/share/factory/hdd
wget https://openqa.opensuse.org/tests/2128758/asset/hdd/opensuse-15.4-x86_64-140.1-gnome@64bit.qcow2
script/openqa-clone-job --dir /hdd/openqa-devel/openqa/share/factory --show-progress --host http://localhost:9526 --skip-deps --skip-download https://openqa.opensuse.org/tests/2147668 DISTRI=opensuse VERSION=15.4 BUILD=140.1 ISO= MIRROR_HTTP=http://openqa.opensuse.org/assets/repo/openSUSE-Leap-15.4-oss-Build140.1 MIRROR_HTTPS=https://openqa.opensuse.org/assets/repo/openSUSE-Leap-15.4-oss-Build140.1 HDD_1=opensuse-15.4-x86_64-140.1-gnome@64bit.qcow2 UEFI_PFLASH_VARS=opensuse-15.4-x86_64-140.1-gnome@64bit-uefi-vars.qcow2 ASSET_1= ASSET_2= ASSET_256=
Created job #2316: opensuse-Tumbleweed-DVD-x86_64-Build20220120-openqa_bootstrap@64bit -> http://localhost:9526/t2316

I'm wondering whether I could have achieved that simpler but it wasn't too bad either (except for accidentally using a textmode qcow first).

Unfortunately this failed because it tried to add the repository https://download.opensuse.org/repositories/devel:/openQA/openSUSE_Leap_15.4 Alpha which obviously doesn't exist. I should have expected that. So I suppose I'll have to try using Leap 15.3 maintenance tests instead.

That also means one cannot just C&P the scenario to https://openqa.opensuse.org/admin/job_templates/50 as it was suggested because that's actually the very same job group I've got the Leap 15.4 qcow image from. Not sure where I'd add it instead. Maybe https://openqa.opensuse.org/group_overview/80 (Leap 15.3 Updates)?

Actions #5

Updated by mkittler over 2 years ago

The same procedure for Leap 15.3 using a qcow from Leap 15.3 Updates:

wget https://openqa.opensuse.org/tests/2149564/asset/hdd/opensuse-15.3-x86_64-20220121-4-gnome@64bit.qcow2
script/openqa-clone-job --dir /hdd/openqa-devel/openqa/share/factory --show-progress --apikey 1A0E49A69396DCD1 --apisecret F0F16CA0DD1B2F48 --host http://localhost:9526 --skip-deps --skip-download https://openqa.opensuse.org/tests/2147668 DISTRI=opensuse VERSION=15.3 BUILD=20220121-4 ISO= MIRROR_HTTP= MIRROR_HTTPS= HDD_1=opensuse-15.3-x86_64-20220121-4-gnome@64bit.qcow2 UEFI_PFLASH_VARS=opensuse-15.3-x86_64-20220121-4-gnome@64bit-uefi-vars.qcow2 ASSET_1= ASSET_2= ASSET_256= ASSET_LIBVIRT= ASSET_VIRTUALBOX=

The test is still running but already past the repository configuration. I suppose today VDSL 100 really pays off…

Actions #6

Updated by mkittler over 2 years ago

  • Status changed from In Progress to Feedback

The test passed locally. So I have added openqa_bootstrap to https://openqa.opensuse.org/admin/job_templates/80. I'll check the build results on o3 when a new build has been tested on https://openqa.opensuse.org/group_overview/80.


Note that there's also openqa_bootstrap_container. The ACs don't mention it and it is currently failing on TW (likely due to an unrelated SSL problem, see #105256). However, the test is passing locally against Leap 15.3 so I've been adding it as well. In order to avoid duplication between the groups I've moved the settings from the job template to a test suite (like it was already the case for openqa_bootstrap). If the container test is not wanted we can just remove it again.

Actions #7

Updated by mkittler about 2 years ago

  • Status changed from Feedback to Resolved

AC1 is fullfilled because the test openqa_bootstrap test passes: https://openqa.opensuse.org/tests/2152913

The openqa_boostrap_container test fails in the same way as it currently fails for TW. I've been adding a comment with a bugref in the job. I suppose we can keep it as automatic takeover should work here reliably (as it is not a sporadic issue). It is strange that I couldn't reproduce the problem locally, though. I commented on the relevant ticket (#105256#note-3) so I suppose I can resolve this one.

Actions

Also available in: Atom PDF