Project

General

Profile

action #95281

error on "Next & previous results": ajax error message and no results showing up

Added by okurz 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-07-09
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

From favogt:

I'm getting a 500 on https://openqa.opensuse.org/tests/1831535#next_previous due to [2021-07-09T09:20:25.0092 UTC] [error] [sNVmMoPb-wu6] Can't call method "id" on an undefined value at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Test.pm line 119.. Known?

Steps to reproduce

Go to https://openqa.opensuse.org/tests/1831490#next_previous or any other "next_previous" on o3 at least. Problem is reproducible on osd as well: https://openqa.suse.de/tests/5989050#next_previous


Related issues

Related to openQA Project - action #94937: Distinguish comment types on jobs on /tests (maybe optional) size:SResolved2021-05-28

Copied to openQA Infrastructure - action #95293: Monitoring alerts on errors in logs on o3 (was: followup to: error on "Next & previous results": ajax error message and no results showing up) size:MWorkable2021-07-09

History

#1 Updated by okurz 5 months ago

line 119 was recently introduced by https://github.com/os-autoinst/openQA/pull/4014 so I propose a revert for now with
https://github.com/os-autoinst/openQA/pull/4031

#2 Updated by okurz 5 months ago

  • Status changed from New to In Progress
  • Assignee set to okurz

can you approve my revert in https://github.com/os-autoinst/openQA/pull/4031 ? I would merge ASAP and manually trigger a deploy to fix the problems on o3+osd

#3 Updated by okurz 5 months ago

  • Related to action #94937: Distinguish comment types on jobs on /tests (maybe optional) size:S added

#4 Updated by okurz 5 months ago

deployed a revert on both o3 and osd with for i in o3 osd; do ssh $i 'zypper -n in openQA'; done

#5 Updated by okurz 5 months ago

  • Copied to action #95293: Monitoring alerts on errors in logs on o3 (was: followup to: error on "Next & previous results": ajax error message and no results showing up) size:M added

#6 Updated by okurz 5 months ago

  • Status changed from In Progress to Resolved

created a follow-up #95293

#7 Updated by tinita 5 months ago

Sorry, will try to fix my original PR

#8 Updated by tinita 5 months ago

The problem was that some bugrefs don't have an entry in the Bugs table. I wasn't aware of that.
I was able to remove the problematic statement as it was not needed anyway, and in the other functions $bug was already checked first before accessing methods.

I added a bugref without a Bugs database entry now to the tests.

https://github.com/os-autoinst/openQA/pull/4035

Also available in: Atom PDF