Project

General

Profile

action #94937

QA - coordination #91646: [saga][epic] SUSE Maintenance QA workflows with fully automated testing, approval and release

coordination #89062: [epic] Simplify review for SUSE QAM

Distinguish comment types on jobs on /tests (maybe optional) size:S

Added by okurz 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2021-05-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Motivation

As a test reviewer and member of one of many QA squads I want to find unreviewed openQA test failures on /tests to have access to a single page showing all failures needing review work. Being able to distinguish the comment type same as we do on /tests/overview and the list of "Next & Previous" jobs can help as well as prevent confusion what the "comment" icon actually means

Also see parent #89062

Acceptance criteria

  • AC1: At least completed tests /tests shows comment type icons same as we do on /tests/overview and the list of "Next & Previous" jobs (on request or always)

Suggestions

So far /tests already shows a comments icon but makes no distinction like on /tests/overview or "next & previous" between "plain comment", "label" or "bugref". We should extend that to distinguish comment types.
If there is a significant performance impact only enable on request, e.g. a hidden query parameter

  • Try t/ui/01-list.t and see if you can extend it
  • Distinguish between "plain comment", "label" and "bugref" same as we do in /tests/overview and "next & previous"
  • Optional: Add UI element to configure this, e.g. again like on /tests/overview
testlist-comments-after.png (102 KB) testlist-comments-after.png Screenshot after tinita, 2021-07-01 13:48
testlist-comments-before.png (101 KB) testlist-comments-before.png Screenshot before tinita, 2021-07-01 13:48
11642
11645

Related issues

Related to openQA Project - action #95281: error on "Next & previous results": ajax error message and no results showing upResolved2021-07-09

Copied from openQA Project - action #93246: List all unreviewed failed (or incomplete) jobs on /tests on request size:MWorkable2021-05-28

History

#1 Updated by okurz 3 months ago

  • Copied from action #93246: List all unreviewed failed (or incomplete) jobs on /tests on request size:M added

#2 Updated by tinita 3 months ago

  • Status changed from Workable to In Progress
  • Assignee set to tinita

#3 Updated by tinita 3 months ago

Implemented and pushed to my fork.
Now finding out which tests to change and/or extend.

#4 Updated by okurz 3 months ago

Does t/ui/01-list.t from my suggestions not work?

#5 Updated by tinita 3 months ago

okurz wrote:

Does t/ui/01-list.t from my suggestions not work?

My approach was to first let CI run all tests and see if I broke something, and go from there.

#7 Updated by okurz 3 months ago

Looks good. Maybe except for the unexpected difference in line wrapping.

#8 Updated by tinita 3 months ago

I added a test for an open bugref.
Will add tests for the other cases as well.

Note: Showing comment data was completely disabled in the past due to performance reasons for the running and scheduled tests, according to the comments in the code I found.
So I implement this only for the finished tests.

Note to self:

# Use this list for showing relevant tests with coments, bugrefs and labels
my %ids = qw( 1811909 1 1811550 1 1811761 1 1811897 1 1811912 1 1812121 1 1811554 1 );
@jobs = grep { $ids{ $_->id } } @jobs;
# in loop:
if ($job_id == 1811554) {
    $comment_data{comments} = 2;
}

#9 Updated by tinita 3 months ago

  • Status changed from In Progress to Feedback

#10 Updated by tinita 3 months ago

  • Status changed from Feedback to In Progress

#11 Updated by okurz 3 months ago

  • Status changed from In Progress to Feedback

#12 Updated by okurz 3 months ago

  • Related to action #95281: error on "Next & previous results": ajax error message and no results showing up added

#13 Updated by okurz 3 months ago

likely regression #95281

#14 Updated by tinita 3 months ago

  • Status changed from Feedback to In Progress

#15 Updated by okurz 3 months ago

I fixed #95281 by rolling back with a revert PR and deploy that on both o3 and osd. I also created a follow-up #95293

#16 Updated by tinita 2 months ago

New PR: https://github.com/os-autoinst/openQA/pull/4035

I actually wanted to add this message last week, but didn't see the redmine conflict when I clicked Submit.

#17 Updated by tinita 2 months ago

  • Status changed from In Progress to Feedback

#18 Updated by tinita 2 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF