Project

General

Profile

action #94810

[Leap15.3][qem][qe-core] test fails in qam_zypper_patch

Added by punkioudi 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-06-28
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

It seems that the zypper_add_repos.pm that is scheduled before qam_zypper_patch.pm,doesn't add the needed repo.
Consequently when the test tries to zypper patch the corresponding incidence, it fails.
(It seems that a setting has to be configured)

Observation

openQA test in scenario opensuse-15.3-DVD-Backports-x86_64-gnome@64bit-2G fails in
qam_zypper_patch

Test suite description

Reproducible

Fails since (at least) Build :15953:hello.1616082711

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by msmeissn 3 months ago

i think code that needs to be adjusted is in os-autoinst-distri-opensuse:

sub is_updates_tests {
my $flavor = get_required_var('FLAVOR');
# Incidents might be also Incidents-Gnome or Incidents-Kernel
return $flavor =~ /-Updates$/ || $flavor =~ /-Incidents/;
}

This needs to also handle Backports, perhaps this helps already:

return $flavor =~ /-Updates$/ || $flavor =~ /-Incidents/ || $flavor =~ /-Backports/;

(or rename Backports to Backports-Incidents)

#2 Updated by punkioudi 3 months ago

  • Status changed from New to In Progress
  • Assignee set to punkioudi

#3 Updated by punkioudi 2 months ago

  • Subject changed from [Leap15.3][qem] test fails in qam_zypper_patch to [Leap15.3][qem][qe-core] test fails in qam_zypper_patch
  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#4 Updated by szarate about 2 months ago

  • Target version set to QE-Core: Ready

Also available in: Atom PDF