Project

General

Profile

Actions

action #94495

open

Migrate to InfluxDB 2 when needed (at least when our current OS base has a package)

Added by mkittler almost 3 years ago. Updated 4 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
2021-06-22
Due date:
% Done:

0%

Estimated time:
Tags:

Description

We're currently storing the monitoring data using InfluxDB on monitor.suse.de and are currently using InfluxDB 1.8.6. When browsing the InfluxDB documentation is becomes immediately apparent that version 2 is the current one and that version 2 is more powerful (while one is frequently hitting limits with 1.8, e.g. the complications to solve #93922).

The official documentation has a section for Migrations: https://docs.influxdata.com/influxdb/v2.0/upgrade/v1-to-v2
As a first step it would make sense to read it and come up with a concrete plan. Of course we need to take the Telegraf and Grafana setup into account as well.

Actions #1

Updated by okurz almost 3 years ago

  • Target version set to future

makes sense but currently we are exceeding backlog capacity.

Actions #2

Updated by okurz about 1 year ago

  • Tags set to infra
Actions #3

Updated by okurz 4 months ago

  • Target version changed from future to Ready
Actions #4

Updated by waynechen55 4 months ago

Please help keep all existing account(username/password), database and table when do migration to the latest version. Thanks.

Actions #5

Updated by okurz 4 months ago

  • Subject changed from Migrate to InfluxDB 2 to Migrate to InfluxDB 2 when needed (at least when our current OS base has a package)
  • Priority changed from Normal to Low
  • Target version changed from Ready to future

For now there is a package "influxdb2" but only in the "Databases" repository, not in current openSUSE Leap 15.5 so we can redecide if any later OS that we run needs us to migrate or we have other benefits and the package available.

Actions

Also available in: Atom PDF