Project

General

Profile

action #93724

openqa-review: "Unassigned bugs" includes soft-fails to bugs with assignees

Added by okurz about 1 month ago. Updated 19 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2021-06-09
Due date:
2021-07-03
% Done:

0%

Estimated time:
Difficulty:

History

#1 Updated by okurz about 1 month ago

  • Project changed from QA to openQA Project
  • Category set to Feature requests

#2 Updated by dheidler about 1 month ago

  • Status changed from Workable to In Progress
  • Assignee set to dheidler

#3 Updated by openqa_review about 1 month ago

  • Due date set to 2021-07-03

Setting due date based on mean cycle time of SUSE QE Tools

#4 Updated by dheidler about 1 month ago

  • Status changed from In Progress to Feedback

I was unable to reproduce the issue and will therefore wait for a response from okurz on how he is running openqa-review to generate the dashboard.

#5 Updated by okurz about 1 month ago

Gave the answer already in chat, can copy here:
openqa-review is called with parameters from https://github.com/os-autoinst/openqa_review/blob/master/bin/openqa-review-daily-email#L12 , that is --host ${openqa_host} -n -r -T --query-issue-status --no-empty-sections --include-softfails --running-threshold=2 --exclude-job-groups ^(Released|Development|old)

#7 Updated by okurz about 1 month ago

#8 Updated by tinita 29 days ago

When I wanted to review Dominik's PR yesterday, I found a similar issue, but on the o3 page:
https://w3.nue.suse.com/~okurz/openqa_opensuse_org_status.html#unassigned_box
Under OpenSUSE Tumbleweed you can find:

Arch: x86_64 Status: Red

Existing Product bugs:

soft fails: upgrade_Leap_42.1_kde -> boo1007701
soft fails: extra_tests_on_xfce -> bsc981596
extra_tests_textmode_containers, jeos-containers@64bit_virtio -> gh#containers/podman#10685

And if you go to the bsc981596 link:
https://bugzilla.suse.com/show_bug.cgi?id=981596

you will see that the bug is assigned.

I found out it has to do with the matching (bsc vs. bsc#).
Should I create another ticket for this?

#9 Updated by dheidler 29 days ago

  • Status changed from Feedback to In Progress

I will handle it here

#10 Updated by okurz 29 days ago

Actually if people fail to follow the convention don't clean up after them, raise it as an error within the generated report

#11 Updated by dheidler 29 days ago

The existing regex allows bugrefs without a hash:

bugref_regex = "(poo|boo|bsc|bgo)#?([0-9]+)"

And bugrefs eg. in needles can't have a hash.

The problem is that the openqa_review Issue class is dealing with them inconsistently.

#12 Updated by okurz 29 days ago

I wonder who introduced that inconsistency :D

#13 Updated by dheidler 26 days ago

  • Status changed from In Progress to Feedback

#14 Updated by dheidler 19 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF