Project

General

Profile

Actions

action #93240

closed

test fails in valgrind: fails to compile with gcc11

Added by dimstar over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-05-28
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-JeOS-for-kvm-and-xen-x86_64-jeos-extra@64bit_virtio-2G fails in
valgrind

The valgrind test suite tries to compile a c program
https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/data/valgrind/valgrind-test.c

but using gcc11, this fails (error: maybe uninitialized variable)

Test suite description

Same as jeos, plus some more tests.

Reproducible

Fails since (at least) Build 20190311

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by marxin over 2 years ago

I made an upstream error for it:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100845

For now, we can disable the warning. Do you want me doing a pull request for it?

Actions #3

Updated by ph03nix over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to ph03nix
Actions #4

Updated by ph03nix over 2 years ago

Oh dammit, I was too slow ;-)

Actions #5

Updated by ph03nix over 2 years ago

  • % Done changed from 0 to 90

PR merged: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12631 should be fixed in tomorrow's runs.

Actions #6

Updated by ph03nix over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Guess we can close this

Actions

Also available in: Atom PDF