Project

General

Profile

action #93165

[virtualization] The ppc64le ISO PXE installation repo in OSD is always unmount

Added by simonlm 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Infrastructure
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

We are SAP Hana perf test team. In our daily work, we need to use OpenQA to install ppc64le operating system frequently. Therefore, the installation repo of ppc64le system in http://openqa.suse.de/assets/repo/fixed/ website is very important to us(for example:SLE-12-SP5-Server-DVD-ppc64le-GM-DVD1/). Because we need to use PXE to install the operating system. But ppc64le installation files here are often unmount, which will cause our installation to fail(for example:http://openqa.qa2.suse.asia/tests/34782#step/bootloader/25), so we have to find Alice(xlai) with relevant permissions to manually mount the ISO mirror file for us. This will be a very time-consuming, and our plan is to implement full automation testing later, and if these mirrors are often uninstalled, our automation goals will not be achieved.

Can we find the best solution to solve the problems we are facing? Thank you!

History

#1 Updated by tjyrinki_suse 4 months ago

  • Subject changed from The ppc64le ISO PXE installation repo in OSD is always unmount to [tools] The ppc64le ISO PXE installation repo in OSD is always unmount
  • Start date deleted (2021-05-27)

possibly for tools team to check

#2 Updated by okurz 4 months ago

  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Ready

ok, trying to understand the problem and to help here.

simonlm wrote:

We are SAP Hana perf test team. In our daily work, we need to use OpenQA to install ppc64le operating system frequently. Therefore, the installation repo of ppc64le system in http://openqa.suse.de/assets/repo/fixed/ website is very important to us(for example:SLE-12-SP5-Server-DVD-ppc64le-GM-DVD1/).
Because we need to use PXE to install the operating system. But ppc64le installation files here are often unmount,

what specifically are you referring to with "here"?
The path /var/lib/openqa/factory/repo/fixed/SLE-12-SP5-Server-DVD-ppc64le-GM-DVD1 on osd is a local, manually maintained directory that was not changed since multiple months and is available over http as well as other protocols as long as according services on osd are up which you can expect to be in the same range as http://openqa.suse.de itself (The current availability ratio over the last 6 months is 99.90%, see https://monitor.qa.suse.de/ for reference).

which will cause our installation to fail(for example:http://openqa.qa2.suse.asia/tests/34782#step/bootloader/25), so we have to find Alice(xlai) with relevant permissions to manually mount the ISO mirror file for us. This will be a very time-consuming, and our plan is to implement full automation testing later, and if these mirrors are often uninstalled, our automation goals will not be achieved.

The server http://openqa.qa2.suse.asia is currently not reachable for me and I do not know who the maintainer of that machine is. The SUSE QE Tools team is not maintaining that machine. As long as you are relying on that machine you need to address the according maintainer, likely "Alice (xlai)" is maintaining that machine or know who is. So if the problem is specific to openqa.qa2.suse.asia please assign the ticket to them.

Can we find the best solution to solve the problems we are facing? Thank you!

Alternatives to consider: Use openqa.suse.de

As you stated that you rely on the "GM" assets for installation I assume you conduct performance tests for the purpose of guarding against performance regressions in SLE maintenance updates, right?

#3 Updated by zyuhu 4 months ago

  • Assignee changed from okurz to xlai

For this issue, Alice already helped deploy a workaround. and we'll keep watching if the issue will happen again.

Re-assign to Alice.

#4 Updated by okurz 4 months ago

  • Subject changed from [tools] The ppc64le ISO PXE installation repo in OSD is always unmount to [virtualization] The ppc64le ISO PXE installation repo in OSD is always unmount

#5 Updated by okurz 4 months ago

  • Target version deleted (Ready)

#6 Updated by xlai about 2 months ago

  • Status changed from Feedback to Resolved

The issue does not happen for 2 months. So mark it resolved.

Also available in: Atom PDF