Project

General

Profile

action #91293

[qac][container] Docker networking between containers is broken

Added by lkocman 3 months ago. Updated 17 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-04-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

seems like test is stuck on login prompt to console

openQA test in scenario opensuse-15.3-DVD-x86_64-extra_tests_textmode_containers@64bit fails in
docker_compose

Test suite description

Maintainer: dheidler. Extra tests about CLI software in container module

Reproducible

Fails since (at least) Build 134.1

Expected result

Last good: 121.2 (or more recent)

Further details

Always latest result in this scenario: latest

History

#2 Updated by okurz 3 months ago

  • Subject changed from Leap 15.3: test fails in docker_compose - stuck at console login to [qac][container] Leap 15.3: test fails in docker_compose - stuck at console login
  • Assignee set to pdostal

lkocman wrote:

Observation

seems like test is stuck on login prompt to console

no, that's not the problem. The tests use a serial terminal. While this is running the main screenshot still shows the mostly unused tty.
https://openqa.opensuse.org/tests/1702628#step/docker_compose/71 shows
that the line assert_script_run 'curl -s http://127.0.0.1:8080/ | grep "Welcome to nginx!"'; failed but I also do not see more details.

pdostal as test module maintainer I am sure you can help here

#3 Updated by pdostal 3 months ago

  • Status changed from New to In Progress

#4 Updated by pdostal 3 months ago

The problem disappears when firewalld is disabled.

#5 Updated by pdostal 3 months ago

  • Subject changed from [qac][container] Leap 15.3: test fails in docker_compose - stuck at console login to [qac][container] Docker networking between containers is broken

#6 Updated by jlausuch 17 days ago

  • Status changed from In Progress to Resolved

The issue was this bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1184954
And the tests were tagged accordingly.
In 15.3 updates, the problem is gone: https://openqa.opensuse.org/tests/1838055#step/docker_compose/1

Closing.

Also available in: Atom PDF