Project

General

Profile

action #88355

test fails in installation - split autoinst.xml for Leap only

Added by mlin7442 over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2021-02-01
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario opensuse-15.3-DVD-x86_64-autoyast_gnome@64bit fails in
installation

Test suite description

Testing autoyast installation with given profile and expect SLES with gnome. Please, see the profile for more details. Profile is available in distri git repo under data subdirectory. Same as autoyast_gnome but with product defined in the profile. Maintainers: riafarov, okurz

openSUSE Leap's product name is changed to Leap, it was openSUSE before, thus we need a split autoyast.xml for Leap only.
We can either expand variable, like we do for SCC_REGCODE and other variables. Or maintain 2 profiles.

Reproducible

Fails since (at least) Build 4.2

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov over 1 year ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)
  • Target version set to SLE 15 SP3

#2 Updated by riafarov over 1 year ago

  • Description updated (diff)
  • Status changed from New to Workable

#3 Updated by riafarov over 1 year ago

MAJOR UPDATE: this is an issue with all autoyast installations, see https://openqa.opensuse.org/tests/overview?arch=&machine=&modules=installation&distri=opensuse&version=15.3&build=65.8&groupid=50#

So we should address all of it with the same solution.

#4 Updated by riafarov over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

#5 Updated by riafarov over 1 year ago

I've checked and there are 2 points. First, TW works well without product being defined, which is not the case for leap. Also, there is a bug https://bugzilla.opensuse.org/show_bug.cgi?id=1181790 on leap when product is defined.
Considering these points, and the fact that we only run 3 AY profiles, I believe that having a separate profiles is a good solution, which will also give us further flexibility in case there are more differences to TW.

#6 Updated by riafarov over 1 year ago

  • Status changed from In Progress to Feedback

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11898

As of now all of the installations fail with https://bugzilla.opensuse.org/show_bug.cgi?id=1181790
Let's see if that gets fixed, we can merge the PR to be prepared and revert in case expectations will be different.

#8 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: autoyast_gnome@uefi-2G
https://openqa.opensuse.org/tests/1684457

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF