Project

General

Profile

Actions

action #88223

closed

[openqa-in-openqa] Remove special-case on load_osautoinst_tests with OPENQA_FROM_GIT

Added by livdywan about 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2021-01-26
Due date:
% Done:

0%

Estimated time:

Description

We have a new test running with OPENQA_CONTAINERS=1 in addition to the existing cases. And during a review of the job template YAML we came across this special-case since the new scenario wouldn't inherit the settings from the openqa_from_git scenario. The main.pm of os-autoinst-distri-openQA has this condition:

# testing from git only tests webui so far
load_osautoinst_tests() unless check_var('OPENQA_FROM_GIT', 1);

From the comment it seems like we should enable more tests to run load_osautoinst_tests. For now the openQA in openQA job group contains OPENQA_FROM_GIT=1 in the scenario definition in YAML.

Acceptance Criteria

  • AC1:

Suggestions

  • Drop OPENQA_FROM_GIT=1 special-case from main.pm
  • Extend use cases for load_osautoinst_tests and rename the flag accordingly
Actions #1

Updated by okurz about 3 years ago

you told me that tickets with links are much more helpful, so I suggest you do the same :) Please reference the ticket that adds the new scenario and if you can an openQA test that shows the problem you mean … assuming that you actually see a problem? Please select the category for ticket accordingly as well. I assume "Concrete Bugs"? However so far it's not really that "concrete".

Actions #2

Updated by okurz about 3 years ago

  • Category set to Regressions/Crashes
  • Target version set to Ready
Actions #3

Updated by livdywan about 3 years ago

  • Description updated (diff)

okurz wrote:

you told me that tickets with links are much more helpful, so I suggest you do the same :) Please reference the ticket that adds the new scenario and if you can an openQA test that shows the problem you mean … assuming that you actually see a problem? Please select the category for ticket accordingly as well. I assume "Concrete Bugs"? However so far it's not really that "concrete".

I filed it during a call with @ilausuch and left it as New because we weren't completely sure of the intention. Apparently I closed the tab without adding more details. Thank you for asking!

Actions #4

Updated by okurz about 3 years ago

  • Target version changed from Ready to future
Actions #5

Updated by okurz almost 2 years ago

  • Status changed from New to Resolved
  • Assignee set to okurz

The condition might have been misread because it's unless and not if. So load_osautoinst_tests is actually called with only the exception of trying out openQA from git. I think the os-autoinst integration with openQA is by now better covered by running the openQA full-stack test as part of os-autoinst CI tests itself.

Actions

Also available in: Atom PDF