Project

General

Profile

action #87713

[qe-yast][qe-core][qem][QU] test fails in scc_registration (multipath not tested on Full images)

Added by tjyrinki_suse 9 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Full-QR-ppc64le-multipath@ppc64le-no-tmpfs fails in
scc_registration

Test suite description

Maintainer: okurz

Test installation on machine with virtual multipath hardware. Only tests succesful detection of multipath and installation. No functional testing of multipath itself.

Reproducible

Fails since (at least) Build 376.10

Expected result

See Online-QR's result at: https://openqa.suse.de/tests/5259394
This is the first time the test is tried to run on Full images.
Also SP3 Yast tests do not test multipath on Full: https://openqa.suse.de/tests/overview?distri=sle&version=15-SP3&build=124.5&groupid=129

This task might be for QE Yast to enable multipath testing on Full images at some point.

Further details

Always latest result in this scenario: latest

History

#1 Updated by tjyrinki_suse 9 months ago

  • Status changed from New to Workable

#2 Updated by tjyrinki_suse 9 months ago

  • Description updated (diff)

#3 Updated by tjyrinki_suse 9 months ago

  • Subject changed from [qe-core][qem][QU] test fails in scc_registration to [qe-core][qem][QU] test fails in scc_registration (multipath not tested on Full images)
  • Description updated (diff)

#4 Updated by mgrifalconi 9 months ago

  • Assignee set to mgrifalconi

#5 Updated by mgrifalconi 9 months ago

I did some investigation. It's not possible to clone the test since the original image is gone, so I used ISO="SLE-15-SP2-Full-x86_64-GMC-Media1.iso" which is close enough I suppose.

Findings:
The full image needs multipath before scc_registration and the online image vice-versa.

Online image, scc_registration and then multipath: OK https://openqa.suse.de/tests/5294329

Full image, scc_registration and then multipath: FAIL https://openqa.suse.de/tests/5294243
Full image, multipath and then scc_registration: OK https://openqa.suse.de/tests/5311261

I assume the same issue of the Full image is also here https://openqa.suse.de/tests/5294239 for s390

#6 Updated by tjyrinki_suse 9 months ago

  • Subject changed from [qe-core][qem][QU] test fails in scc_registration (multipath not tested on Full images) to [qe-yast][qe-core][qem][QU] test fails in scc_registration (multipath not tested on Full images)

Adding qe-yast tag too since this would be for them but so far we've often dealt with QU issues.

Note that all of the Full images QU tests are new, the flavor did not exist before. Case-by-case it can be considered whether to run the same test also on Full-QR, not just Online-QR.

#7 Updated by mgrifalconi 9 months ago

  • Status changed from Workable to Rejected

Seems like I missed the same ticket for a different arch https://progress.opensuse.org/issues/87710 and me and Dominik worked in parallel on the same thing.

Going to close this since it's now a duplicate and a PR has been merged.

For the record, I am not 100% happy on applying workarounds on the test schedule instead of following-up with a product bug to clarify why the images work in a different way but I understand it's a cheaper solution and the problem is not that relevant.

Also available in: Atom PDF