Project

General

Profile

action #81703

coordination #58184: [saga][epic][use case] full version control awareness within openQA, e.g. user forks and branches, fully versioned test schedules and configuration settings

coordination #92314: [epic] Cleanup vars.json as initial information container between openQA worker and isotovideo - further cleanup

The values of 'ISO' and 'HDD' includes absolute path in vars.json

Added by Xiaojing_liu 7 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2021-01-04
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Motivation

For now, our jobs' vars.json has "ISO": "/var/lib/openqa/pool/14/SLE-15-SP3-Online-s390x-Build118.3-Media1.iso", according to #80372, we could let the value do not include the work directory information.

Acceptance criteria

  • AC1: the values of ISO and HDD don't include the work directory, should be a file name from openQA side.
  • AC2: still support the values that with an absolute path

History

#1 Updated by Xiaojing_liu 7 months ago

  • Blocked by coordination #80372: [epic] Cleanup vars.json as initial information container between openQA worker and isotovideo added

#2 Updated by Xiaojing_liu 7 months ago

  • Blocked by deleted (coordination #80372: [epic] Cleanup vars.json as initial information container between openQA worker and isotovideo)

#3 Updated by Xiaojing_liu 7 months ago

  • Parent task set to #80372

#4 Updated by okurz 7 months ago

  • Target version set to future

#5 Updated by okurz 3 months ago

  • Category set to Feature requests
  • Status changed from New to Workable
  • Target version changed from future to Ready

#6 Updated by Xiaojing_liu 3 months ago

  • Assignee set to Xiaojing_liu

#7 Updated by openqa_review 3 months ago

  • Due date set to 2021-05-05

Setting due date based on mean cycle time of SUSE QE Tools

#8 Updated by cdywan 3 months ago

  • Description updated (diff)

#9 Updated by okurz 3 months ago

  • Status changed from Workable to In Progress

#11 Updated by Xiaojing_liu 3 months ago

  • Due date changed from 2021-05-05 to 2021-05-12

I reset the due date because next week I will be on vacation, so can't check results. One pr is merged, and one is ready. I think we need to check the result after this feature is deployed on OSD and o3.

#12 Updated by okurz 3 months ago

  • Parent task changed from #80372 to #92314

#13 Updated by cdywan 3 months ago

Xiaojing_liu wrote:

Another pull request: https://github.com/os-autoinst/openQA/pull/3863

The PR got merged, now I guess it's wait and see

#14 Updated by Xiaojing_liu 2 months ago

  • Status changed from In Progress to Feedback

Fix a regression issue: https://github.com/os-autoinst/os-autoinst/pull/1667.
The pr has been deployed on o3 and didn't find other issue.
We could wait for more time to see the results on OSD.

#15 Updated by okurz 2 months ago

  • Status changed from Feedback to Resolved

https://openqa.opensuse.org/tests/1739279 is fine again. I assume the problem is fixed and we are done with the feature. https://openqa.opensuse.org/tests/1739279/file/vars.json also shows that assets do not have a worker specific absolute path so all good

#16 Updated by okurz 2 months ago

  • Due date deleted (2021-05-12)

Also available in: Atom PDF