Project

General

Profile

action #81266

action #70981: [opensuse][qem] Improve zfs test

Improve output of zfs test failure

Added by ph03nix over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-12-22
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.3-DVD-x86_64-extra_tests_filesystem@64bit fails in
zfs

Test suite description

Maintainer: okurz@suse.de

Filesystem related tests, for example snapper and btrfs features.

Reproducible

Fails since (at least) Build 4.2

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #71461: [opensuse] test fails in zfs - zfs kernel module not found on JumpNew

History

#1 Updated by ph03nix over 1 year ago

Looking into this, if this is a test issue or if not yet working on 15.3

#2 Updated by ph03nix over 1 year ago

15.3 is currently not included in the test case because there are no builds for it yet. I'm having a look if I can help out.

#3 Updated by ph03nix over 1 year ago

  • % Done changed from 0 to 60

15.3 is not yet available in OBS as distribution. Cannot build.

#4 Updated by ph03nix over 1 year ago

Improving the output of the test module to make the source of the test failure more obvious.

#5 Updated by ph03nix over 1 year ago

  • Subject changed from test fails in zfs to Improve output of zfs test failure

#6 Updated by ph03nix over 1 year ago

  • % Done changed from 60 to 80
  • Parent task set to #70981

#7 Updated by ph03nix over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

#8 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_filesystem
https://openqa.opensuse.org/tests/1582578

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#9 Updated by ph03nix over 1 year ago

I'm wondering how this test gets scheduled on 15-SP3, when the only place where this is defined is main_common.pm with

loadtest "console/zfs"  if (is_leap(">=15.1") && is_x86_64 && !is_jeos);

IMHO this test should not be executed there.

Edit: My bad. This is Leap, there it is ok.

I make this a softfailure, since it's a known issue that there are no builds yet available. This should not do harm to the other test cases.

#11 Updated by tjyrinki_suse about 1 year ago

  • Related to action #71461: [opensuse] test fails in zfs - zfs kernel module not found on Jump added

Also available in: Atom PDF