Project

General

Profile

action #81036

[opensuse] rstudio_server can fail in various ways

Added by dimstar over 1 year ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_rstudio@64bit fails in
rstudio_server

In Snapshow 1213 (no changes related to R-Studio happened to my knowledge), the test for rstudio-server fails, but it can fail in various ways upon retry:

  • The Firefox tab with RStudio server is only called 'Rstudio' instead of 'Rstudio server' (making the needle not match)
  • In case above does not happen, then later on, it failed to load the directory tree to create a new project, and only presented an empty window

Test suite description

Maintainer: dancermak. Test rstudio-desktop and rstudio-server

Reproducible

Fails since (at least) Build 20201213

Expected result

Last good: 20201212 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dancermak over 1 year ago

No idea what is going on there, the issue is not reproducible locally. My only guess is that maybe the worker could be overloaded and this is a timing issue?

#2 Updated by okurz over 1 year ago

Creating a more resilient needle for https://openqa.opensuse.org/tests/1506936#step/rstudio_server/24 should be easy, just not cover the string "server" in the needle. But for the other point and your hypothesis: The only real sustainable way is to increase the robustness of the test code and foresee that issues like these can happen.

#3 Updated by tjyrinki_suse about 1 year ago

  • Subject changed from rstudio_server can fail in various ways to [opensuse] rstudio_server can fail in various ways
  • Start date deleted (2020-12-14)

#4 Updated by dancermak 6 months ago

  • Status changed from New to Rejected

RStudio openQA tests have been deleted from os-autoinst-distri-opensuse.

Also available in: Atom PDF