Project

General

Profile

action #80276

[sporadic][timeboxed:12h] autoyast_reinstall@s390x-kvm-sle12 fails in installation

Added by syrianidou_sofia 11 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-11-24
Due date:
% Done:

0%

Estimated time:

Description

Observation

During installation on s390x-kvm-sle12, the worker is trying to use pty but even though grub seems to be loaded after failure, it might take longer than expected.

To try reproducing issue manually see https://gitlab.suse.de/qsf-y/qa-sle-functional-y/-/blob/master/Manual_Testing_Guide.md#zkvm

Investigate the issue and the failure frequency.

Maybe increasing the timeout would solve it.

openQA test in scenario sle-15-SP3-Online-s390x-autoyast_reinstall@s390x-kvm-sle12 fails in
installation

Test suite description

Parent job produces autoyast profile after successful completion. This test uses generated profile to do autoyast installation.

Reproducible

Fails since (at least) Build 44.1

Expected result

Last good: 78.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia 11 months ago

  • Project changed from openQA Tests to qe-yast

#2 Updated by riafarov 11 months ago

  • Target version set to SLE 15 SP3

#3 Updated by riafarov 11 months ago

  • Subject changed from [sporadic] autoyast_reinstall@s390x-kvm-sle12 fails in installation to [sporadic][timeboxed:12h] autoyast_reinstall@s390x-kvm-sle12 fails in installation
  • Description updated (diff)
  • Status changed from New to Workable

#4 Updated by riafarov 11 months ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

#5 Updated by riafarov 11 months ago

  • Status changed from In Progress to Feedback

#6 Updated by riafarov 11 months ago

  • Status changed from Feedback to Closed

#7 Updated by riafarov 10 months ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11596

We skip second stage there and try to connect to the VM after installation. There we have grub timeout disabled, so machine won't boot at all if enter is not presses. So sporadically we would wait for 120 for grub, and press enter afterwards when it was not there yet. PR addresses it to wait for grub longer and even if we miss it on the serial, we will select OS to boot still.

#8 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: autoyast_reinstall
https://openqa.suse.de/tests/5286614

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF