Project

General

Profile

action #78007

coordination #76861: Adjust test code for the new partitioner UI

Adjust partitioning_warnings for the UI changes

Added by riafarov over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-11-16
Due date:
% Done:

0%

Estimated time:

Description

We should try to reuse old code, where is still applicable in order to speed up the process, and for the complex actions use REST API.

Scope is openSUSE and SLE 15 SP3.

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-btrfs+warnings@64bit fails in
partitioning_warnings

Test suite description

Reproducible

Fails since (at least) Build 20201113

Expected result

Last good: 20201112 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov over 1 year ago

  • Description updated (diff)

#2 Updated by riafarov over 1 year ago

  • Status changed from New to Workable

#3 Updated by oorlov over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#4 Updated by oorlov over 1 year ago

I've decided to use libyui in the module. Also I've split the module to several ones to make the tests more scope-isolated. PR for the no root warning: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11559

#5 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: btrfs+warnings
https://openqa.opensuse.org/tests/1534649

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#6 Updated by oorlov over 1 year ago

  • Status changed from In Progress to Feedback

#7 Updated by oorlov over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF