Project

General

Profile

action #76900

unstable/flaky/sporadic t/full-stack.t test failing in CircleCI "worker did not propagate URL for os-autoinst cmd srv within 1 minute"

Added by okurz 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://app.circleci.com/pipelines/github/os-autoinst/openQA/4698/workflows/3fc8c9cf-feb8-435d-b868-76fee3b20bb7/jobs/44844
shows:

RETRY=0 timeout -s SIGINT -k 5 -v $((9 * (0 + 1) ))m tools/retry prove -l --harness TAP::Harness::JUnit --timer t/full-stack.t
[09:55:15] t/full-stack.t .. 374/? # full result panel contents:
# State: scheduled
# Scheduled product: job has not been created by posting an ISO
# 50
[09:55:15] t/full-stack.t .. 376/? 
#   Failed test 'test 1 is running'
#   at t/full-stack.t line 128.

    #   Failed test 'worker did not propagate URL for os-autoinst cmd srv within 1 minute'
    #   at /home/squamata/project/t/lib/OpenQA/Test/FullstackUtils.pm line 195.

    #   Failed test 'developer console for test 1'
    #   at t/full-stack.t line 134.
    # Looks like you failed 2 tests of 3.
[09:55:15] t/full-stack.t .. 377/? 
#   Failed test 'wait until developer console becomes available'
#   at t/full-stack.t line 135.
Bailout called.  Further testing stopped:  findElement: no such element: Unable to locate element: {"method":"css selector","selector":"#log"} at /home/squamata/project/t/lib/OpenQA/SeleniumTest.pm:101
FAILED--Further testing stopped: findElement: no such element: Unable to locate element: {"method":"css selector","selector":"#log"} at /home/squamata/project/t/lib/OpenQA/SeleniumTest.pm:101

Steps to reproduce

To be confirmed if this can be reproduced locally with

make test STABILITY_TEST=1 RETRY=500 FULLSTACK=1 TESTS=t/full-stack.t

Suggestions


Related issues

Related to openQA Project - action #59043: Fix unstable/flaky full-stack test, i.e. remove sleep, and ui testsBlocked2019-11-04

Is duplicate of openQA Project - action #75370: unstable/flaky/sporadic t/full-stack.t failing on master (circleCI) "worker did not propagate URL for os-autoinst cmd srv within 1 minute"Resolved2020-10-272020-11-20

History

#1 Updated by okurz 3 months ago

  • Status changed from New to Feedback

#2 Updated by okurz 3 months ago

  • Related to action #59043: Fix unstable/flaky full-stack test, i.e. remove sleep, and ui tests added

#3 Updated by okurz 3 months ago

  • Is duplicate of action #75370: unstable/flaky/sporadic t/full-stack.t failing on master (circleCI) "worker did not propagate URL for os-autoinst cmd srv within 1 minute" added

#4 Updated by okurz 3 months ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved

duplicate of #75370 but workaround PR merged.

Also available in: Atom PDF