Project

General

Profile

action #73567

openQA tour does not reliably save its state

Added by cdywan 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-10-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The tour doesn't go away unless when quitting on the last tour step.

Suggestions

  • The most recent change to the tour was made in the context of #58304 which added two new steps (https://github.com/os-autoinst/openQA/pull/3471/files).
  • On O3 as of this writing the new code has not been deployed yet, but a a permission error can be observed on the console POST https://openqa.opensuse.org/api/v1/feature 403

Workaround

Click the "Quit" button when not showing the last tour step.


Related issues

Related to openQA Project - action #58304: A personal activity view for developers Resolved2019-10-172020-10-17

History

#1 Updated by okurz 9 months ago

  • Description updated (diff)
  • Category set to Concrete Bugs
  • Priority changed from Normal to Low
  • Target version set to future

added workaround

#2 Updated by mkittler 9 months ago

  • Description updated (diff)

Clicking "Quit" does not help (unless one checks the option to dismiss the tour permanently). I suppose clicking "Quit" is actually the last regular step of the tour so I guess that button is always required to be clicked to save the state.

#3 Updated by okurz 9 months ago

  • Subject changed from openQA tour doesn't save its state to openQA tour does not save its state
  • Target version changed from future to Ready

oh, ok. I could not reproduce the issue. Let's put it on the backlog as you convinced me that we poked the hornet's nest now and want the problem to be fixed :)

#4 Updated by mkittler 9 months ago

  • Assignee set to mkittler

#5 Updated by mkittler 9 months ago

  • Status changed from New to In Progress

#6 Updated by mkittler 9 months ago

  • Subject changed from openQA tour does not save its state to openQA tour does not reliably save its state
  • Description updated (diff)

#7 Updated by okurz 9 months ago

  • Related to action #58304: A personal activity view for developers added

#8 Updated by okurz 9 months ago

  • Status changed from In Progress to Resolved

PR merged. It's deployed to o3 without problems observed so far however I did not actually test the feature tour.

Also available in: Atom PDF