Project

General

Profile

action #72274

[y] nfs mount timeout investigation

Added by ybonatakis 12 months ago. Updated 12 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-10-06
Due date:
% Done:

0%

Estimated time:

Description

Observation

I file this for investigation of the timeout during the nfs mount.
The network looks ok and i cant see anything wrong from the y2logs. The logs ends the following

2020-10-06 01:04:29 <1> s390kvm086(11263) [Ruby] clients/nfs_server.rb(main):156 NFS module finished
2020-10-06 01:04:29 <1> s390kvm086(11263) [Ruby] clients/nfs_server.rb(main):157 ----------------------------------------
2020-10-06 01:04:29 <1> s390kvm086(11263) [Interpreter] clients/nfs-server.rb:10 Called YaST client returned.
2020-10-06 01:04:29 <0> s390kvm086(11263) [Interpreter] clients/nfs-server.rb:10 Called YaST client returned: `ws_finish
2020-10-06 01:04:29 <1> s390kvm086(11263) [Interpreter] bin/y2start:60 Called YaST client returned.
2020-10-06 01:04:29 <0> s390kvm086(11263) [Interpreter] bin/y2start:60 Called YaST client returned: `ws_finish
2020-10-06 01:04:29 <0> s390kvm086(11263) [ui] YUI.cc(terminateUIThread):254 Sending shutdown message to UI thread
2020-10-06 01:04:29 <0> s390kvm086(11263) [ui] YUI.cc(uiThreadMainLoop):378 Shutting down UI main loop
2020-10-06 01:04:29 <0> s390kvm086(11263) [ui] YUI.cc(terminateUIThread):261 UI thread shut down correctly
2020-10-06 01:04:29 <1> s390kvm086(11263) [ncurses] YNCursesUI.cc(~YNCursesUI):121 Stop YNCursesUI
2020-10-06 01:04:29 <1> s390kvm086(11263) [ncurses] NCurses.cc(~NCurses):145 Shutdown NCurses...
2020-10-06 01:04:29 <1> s390kvm086(11263) [ncurses] NCurses.cc(~NCurses):164 NCurses down
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-ini] IniParser.cc(write):942 File /etc/sysconfig/nfs did not change. Not saving.
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-ini] IniParser.cc(write):942 File /etc/idmapd.conf did not change. Not saving.
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-ini] IniParser.cc(write):942 File /etc/os-release did not change. Not saving.
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-ini] IniParser.cc(write):942 File /usr/share/applications/YaST2/org.opensuse.yast.NFSServer.desktop did not change. Not saving.
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-ini] IniParser.cc(write):942 File /usr/share/applications/YaST2/org.opensuse.yast.NFSServer.desktop did not change. Not saving.
2020-10-06 01:04:29 <0> s390kvm086(11263) [Pkg] Y2CCPkg.cc(~Y2CCPkg):64 ~Y2CCPkg
2020-10-06 01:04:29 <0> s390kvm086(11263) [Pkg] PkgModule.cc(destroy):101 Deleting PkgModule object...
2020-10-06 01:04:29 <0> s390kvm086(11263) [Pkg] Callbacks.cc(~CallbackHandler):1925 Deleting callback handler
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-system] SystemAgent.cc(remove_directory):99 Removing temporary file /tmp/YaST2-11263-eK3ktS/exit
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-system] SystemAgent.cc(remove_directory):99 Removing temporary file /tmp/YaST2-11263-eK3ktS/stderr
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-system] SystemAgent.cc(remove_directory):99 Removing temporary file /tmp/YaST2-11263-eK3ktS/stdout
2020-10-06 01:04:29 <0> s390kvm086(11263) [agent-system] SystemAgent.cc(remove_directory):99 Removing temporary file /tmp/YaST2-11263-eK3ktS
2020-10-06 01:04:29 <1> s390kvm086(11263) [liby2] Y2ProgramComponent.cc(result):161 Sending result: `result (nil)
2020-10-06 01:04:29 <0> s390kvm086(11263) [Y2Ruby] binary/Y2RubyComponent.cc(~Y2RubyComponent):45 Destroying Y2RubyComponent
2020-10-06 01:04:29 <1> s390kvm086(11263) [Y2Ruby] binary/YRuby.cc(~YRuby):117 Shutting down ruby interpreter.
2020-10-06 01:04:29 <0> s390kvm086(11263) [YCPDeclarations] ../../src/YCPDeclarations.cc(~YCPDeclarations):221 Destructor called

and no error appears.

openQA test in scenario sle-15-SP3-Online-s390x-yast2_ncurses_gnome@s390x-kvm-sle12 fails in
yast2_nfs_server

Test suite description

Test for yast2 UI, ncurses only.
Test suite requires HDD settings to be set, we use inheritance for that.

Reproducible

Fails since (at least) Build 50.1

Expected result

Last good: 44.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by JERiveraMoya 12 months ago

  • Status changed from New to Rejected

With so much needle required, we cannot afford to have exactly the same coverage for all archs and this test never worked.
Should be a follow-up PR to unschedule it in prod from that test suite in s390x.

#2 Updated by riafarov 12 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)
  • Status changed from Rejected to Workable
  • Target version set to SLE 15 SP3

JERiveraMoya wrote:

With so much needle required, we cannot afford to have exactly the same coverage for all archs and this test never worked.
Should be a follow-up PR to unschedule it in prod from that test suite in s390x.

It was enabled as a part of moving yast2_nfs_server from the Functional job group, so we need to clarify if it worked there before, or did you check already? https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10984 indeed doesn't have verification runs on s390x for this module.

#3 Updated by riafarov 12 months ago

  • Assignee set to riafarov

riafarov wrote:

JERiveraMoya wrote:

With so much needle required, we cannot afford to have exactly the same coverage for all archs and this test never worked.
Should be a follow-up PR to unschedule it in prod from that test suite in s390x.

It was enabled as a part of moving yast2_nfs_server from the Functional job group, so we need to clarify if it worked there before, or did you check already? https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10984 indeed doesn't have verification runs on s390x for this module.

Ok, it was never schedule on s390x: https://openqa.suse.de/tests/overview?arch=&machine=&modules=yast2_nfs_server&distri=sle&version=15-SP3&build=23.1&groupid=110#

I will create PR to unschedule.

#4 Updated by riafarov 12 months ago

  • Status changed from Workable to Rejected

Also available in: Atom PDF