Project

General

Profile

action #71743

[qe-core][qam] [maint] test fails in dracut_enhanced - too many levels of recursion in macro expansion

Added by vsvecova 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-09-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The test fails on running rpmbuild -bp dracut.spec --nodeps and throws Too many levels of recursion in macro expansion error.

openQA test in scenario sle-12-SP5-Server-DVD-Updates-x86_64-qam-dracut-basic@64bit fails in
dracut_enhanced

Test suite description

Maintainer: emiura@suse.com

Reproducible

Fails since (at least) Build 20200922-1

Expected result

Last good: 20200918-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by emiura 7 months ago

rpmbuild is printing an error: "too many levels of recursion in macro expansion. it is likely caused by recursive macro declaration" but so far I am unable to reproduce it locally. I'll try to download the disk image from openqa and see if I find something.

#2 Updated by emiura 7 months ago

Downloaded the vm image from openqa and executed it locally, indeed it reproduces the issue.

#3 Updated by emiura 7 months ago

After much debugging, found that the issue is being caused by systemd-rpm-macros update.

#4 Updated by emiura 7 months ago

Ok, this is a regression caused by systemd-rpm-macros update.

#5 Updated by tjyrinki_suse 6 months ago

  • Status changed from New to Workable

#6 Updated by tjyrinki_suse 5 months ago

  • Subject changed from [qam] [maint] test fails in dracut_enhanced - too many levels of recursion in macro expansion to [qe-core][qam] [maint] test fails in dracut_enhanced - too many levels of recursion in macro expansion

#7 Updated by emiura 5 months ago

  • Status changed from Workable to Resolved

The issue was caused by regression on systemd-rpm-macros. bsc#1177034 created, issue fixed. Closing this issue.

Also available in: Atom PDF