Project

General

Profile

action #70252

Dependency problem: Parent shown as passed instead of failed

Added by ggardet_arm 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2020-08-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
easy
Tags:

Description

On https://openqa.opensuse.org/tests/overview?distri=opensuse&version=Jump%3A15.2&build=39.1&groupid=75 you can check children of create_hdd_textmode test which failed.
They are all canceled due to the parent failure, but the logo is green and claims:

1 chained parent
dependency passed

which is wrong.

History

#1 Updated by ggardet_arm 5 months ago

  • Tags set to webui

#2 Updated by mkittler 5 months ago

  • Assignee set to mkittler
  • Difficulty set to easy

I can reproduce it locally. The problem should be very easy to fix.

#3 Updated by mkittler 5 months ago

  • Category set to Concrete Bugs
  • Status changed from New to In Progress

#4 Updated by okurz 5 months ago

  • Target version set to Ready

#5 Updated by mkittler 5 months ago

  • Status changed from In Progress to Resolved

The PR has been merged and deployed. The dependency icons besides the skipped jobs are now red and the tooltip says "dependency failed".

Also available in: Atom PDF