Project

General

Profile

action #69688

[y] test fails in yast2_rmt

Added by dimstar about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-08-07
Due date:
2020-09-08
% Done:

0%

Estimated time:
5.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
yast2_rmt

yast2-rmt was changed to no longer include the host name as part of the CA, the test needs thus to check for a current representation of the CA name

script_run("openssl x509 -noout -subject -in 'rmt.crt' | grep 'rmt1.susetest.org'") && die "Incorrect name in certificate ?";

Seems that we need to adjust this check, so it matches the output.
We might rethink the way we validate generation of the certificate too.

Test suite description

Maintainer: qsf-y Test for yast2 UI, ncurses only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.
riafarov set TIMEOUT_SCALE to improve stability of the test.

Reproducible

Fails since (at least) Build 20200801

Expected result

Last good: 20200731 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla about 2 years ago

  • Subject changed from test fails in yast2_rmt to [y] test fails in yast2_rmt

#2 Updated by riafarov about 2 years ago

  • Due date set to 2020-09-08
  • Priority changed from Normal to High
  • Target version set to SLE 15 SP3

#3 Updated by riafarov about 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#4 Updated by riafarov about 2 years ago

  • Assignee set to riafarov

#6 Updated by riafarov about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF