Project

General

Profile

action #68203

[SLE][Migration][backlog] test fails in zypper_migration - Need BREAK_DEPS for 'zypper migration'

Added by hjluo 27 days ago. Updated 13 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-06-18
Due date:
% Done:

100%

Estimated time:
16.00 h
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-Milestone-aarch64-online_sles15_rmt_basesys-srv-phub_def_full_zypp@aarch64 fails in
zypper_migration

Test suite description

Reproducible

Fails since (at least) Build 101.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli 22 days ago

  • Subject changed from [SLE][Migration][SLE15SP2][Milestone] test fails in zypper_migration - Need BREAK_DEPS for 'zypper migration' to [SLE][Migration][backlog] test fails in zypper_migration - Need BREAK_DEPS for 'zypper migration'
  • Estimated time set to 16.00 h

Move to backlog.

#2 Updated by hjluo 17 days ago

  • Status changed from New to In Progress
  • Assignee set to hjluo
  • % Done changed from 0 to 10

contact the zypper team to see if there any options for zypper migration to break the deps.

#3 Updated by hjluo 15 days ago

  • % Done changed from 10 to 20

Michael Andres ma@suse.com
Mon 6/29/2020 6:03 PM

Hi.

'zypper migration' is a plugin not maintained by the zypp team, but AFAIK by
Vladimir Nadvornik.

For zypper itself there is no option or way to auto-choose some conflict
reolution. There's just the '--force' option which allows the resolver to
delete packages in order to create a consistent system.

Michael Andres


for this particular case, there is option --allow-vendor-change.
There is no generic commandline option for breaking dependencies, this
requires user interaction.

Vladimir


at the link you sent, the the reason why zypper did not solve it
automatically is that there was a vendor change from SUSE to openSUSE.

--allow-vendor-change tells zypper to allow this change without asking.

I don't know if this is the only conflict you see. It won't help with
other types of conflict.

Vladimir


#4 Updated by coolgw 14 days ago

i found a crash happen ?
https://openqa.nue.suse.com/tests/4363529#step/zypper_migration/17

That was caused by #/usr/bin/appstreamcli refreshcash
Stack trace of thread 18623:
#0 0x0000ffffaa8c7828 raise (libc.so.6)
#1 0x0000ffffaacb55e8 g_log_default_handler (libglib-2.0.so.0)
#2 0x0000ffffaacb57e8 g_logv (libglib-2.0.so.0)
#3 0x0000ffffaacb5a04 g_log (libglib-2.0.so.0)
#4 0x0000ffffaacf2540 g_variant_new_parsed_va (libglib-2.0.so.0)
#5 0x0000ffffaacf26a8 g_variant_builder_add_parsed (libglib-2.0.so.0)
#6 0x0000ffffaadd24fc n/a (libappstream.so.4)
#7 0x0000ffffaadc26d8 n/a (libappstream.so.4)
#8 0x0000ffffaadc77c4 as_cache_file_save (libappstream.so.4)
#9 0x0000ffffaadc7b58 as_pool_save_cache_file (libappstream.so.4)
#10 0x0000ffffaadc7d3c as_pool_refresh_cache (libappstream.so.4)
#11 0x0000aaaab722f398 n/a (appstreamcli)
#12 0x0000aaaab722c1c4 n/a (appstreamcli)
#13 0x0000ffffaa8b3da4 __libc_start_main (libc.so.6)
#14 0x0000aaaab722b6c4 n/a (appstreamcli)

it's a bug bsc#1172264 https://bugzilla.suse.com/show_bug.cgi?id=1172264
I've updated the bug report with this ticket information.

#5 Updated by hjluo 14 days ago

  • % Done changed from 20 to 50

#7 Updated by hjluo 13 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

PR merged.

Also available in: Atom PDF