Project

General

Profile

action #67822

[tools] When using refspec for svirt-xen-hvm , openQA-SUT-2 fails

Added by syrianidou_sofia over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Support
Target version:
-
Start date:
2020-06-08
Due date:
2020-06-23
% Done:

0%

Estimated time:
Difficulty:

Description

Using refsep tool in order to run a test on svirt-xen-hvm, will fail at bootloader_svirt if the test is assigned to openQA-SUT-2.

[2020-06-08T11:18:53.923 CEST] [debug] <<< backend::baseclass::run_ssh(cmd="cat > /var/lib/libvirt/images/openQA-SUT-2.xml", hostname="openqaw5-xen.qa.suse.de", password="SECRET", username=undef, keep_open=1)
[2020-06-08T11:18:53.923 CEST] [debug] <<< backend::baseclass::new_ssh_connection(blocking=1, username=undef, hostname="openqaw5-xen.qa.suse.de", password="SECRET", keep_open=1)
[2020-06-08T11:18:54.067 CEST] [debug] <<< backend::baseclass::run_ssh_cmd(cmd="virsh  destroy openQA-SUT-2 |& grep -v \"\\(failed to get domain\\|Domain not found\\)\"", wantarray=0, keep_open=1, username=undef, hostname="openqaw5-xen.qa.suse.de", password="SECRET")
[2020-06-08T11:18:54.067 CEST] [debug] <<< backend::baseclass::run_ssh(cmd="virsh  destroy openQA-SUT-2 |& grep -v \"\\(failed to get domain\\|Domain not found\\)\"", password="SECRET", hostname="openqaw5-xen.qa.suse.de", username=undef, wantarray=0, keep_open=1)
[2020-06-08T11:18:54.068 CEST] [debug] <<< backend::baseclass::new_ssh_connection(blocking=1, password="SECRET", hostname="openqaw5-xen.qa.suse.de", username=undef, keep_open=1, wantarray=0)
[2020-06-08T11:18:54.245 CEST] [debug] [run_ssh_cmd(virsh  destroy openQA-SUT-2 |& grep -v "\(failed to get domain\|Domain not found\)")] stdout:
error: Failed to destroy domain openQA-SUT-2
error: internal error: Failed to destroy domain '817'


[2020-06-08T11:18:54.245 CEST] [debug] [run_ssh_cmd(virsh  destroy openQA-SUT-2 |& grep -v "\(failed to get domain\|Domain not found\)")] exit-code: 0
[2020-06-08T11:18:54.245 CEST] [debug] <<< backend::baseclass::run_ssh_cmd(cmd="virsh  undefine --snapshots-metadata openQA-SUT-2 |& grep -v \"\\(failed to get domain\\|Domain not found\\)\"", username=undef, hostname="openqaw5-xen.qa.suse.de", password="SECRET", wantarray=0, keep_open=1)
[2020-06-08T11:18:54.245 CEST] [debug] <<< backend::baseclass::run_ssh(cmd="virsh  undefine --snapshots-metadata openQA-SUT-2 |& grep -v \"\\(failed to get domain\\|Domain not found\\)\"", keep_open=1, wantarray=0, username=undef, hostname="openqaw5-xen.qa.suse.de", password="SECRET")
[2020-06-08T11:18:54.246 CEST] [debug] <<< backend::baseclass::new_ssh_connection(keep_open=1, wantarray=0, blocking=1, username=undef, hostname="openqaw5-xen.qa.suse.de", password="SECRET")
[2020-06-08T11:18:54.420 CEST] [debug] [run_ssh_cmd(virsh  undefine --snapshots-metadata openQA-SUT-2 |& grep -v "\(failed to get domain\|Domain not found\)")] stdout:
error: Failed to undefine domain openQA-SUT-2
error: Requested operation is not valid: cannot undefine transient domain


[2020-06-08T11:18:54.420 CEST] [debug] [run_ssh_cmd(virsh  undefine --snapshots-metadata openQA-SUT-2 |& grep -v "\(failed to get domain\|Domain not found\)")] exit-code: 0
[2020-06-08T11:18:54.420 CEST] [debug] <<< backend::baseclass::run_ssh_cmd(cmd="virsh  define /var/lib/libvirt/images/openQA-SUT-2.xml", username=undef, password="SECRET", hostname="openqaw5-xen.qa.suse.de", wantarray=0, keep_open=1)
[2020-06-08T11:18:54.421 CEST] [debug] <<< backend::baseclass::run_ssh(cmd="virsh  define /var/lib/libvirt/images/openQA-SUT-2.xml", username=undef, password="SECRET", hostname="openqaw5-xen.qa.suse.de", keep_open=1, wantarray=0)
[2020-06-08T11:18:54.421 CEST] [debug] <<< backend::baseclass::new_ssh_connection(username=undef, password="SECRET", hostname="openqaw5-xen.qa.suse.de", blocking=1, wantarray=0, keep_open=1)
[2020-06-08T11:18:54.585 CEST] [debug] [run_ssh_cmd(virsh  define /var/lib/libvirt/images/openQA-SUT-2.xml)] stdout:


[2020-06-08T11:18:54.585 CEST] [debug] [run_ssh_cmd(virsh  define /var/lib/libvirt/images/openQA-SUT-2.xml)] stderr:
error: Failed to define domain from /var/lib/libvirt/images/openQA-SUT-2.xml
error: operation failed: domain 'openQA-SUT-2' already exists with uuid 9215f187-45ff-4915-87f7-c7f901a194b3

[2020-06-08T11:18:54.585 CEST] [debug] [run_ssh_cmd(virsh  define /var/lib/libvirt/images/openQA-SUT-2.xml)] exit-code: 1
[2020-06-08T11:18:54.695 CEST] [info] ::: basetest::runtest: # Test died: {
  "args" => [],
  "json_cmd_token" => "geKeVGfx",
  "console" => "svirt",
  "cmd" => "backend_proxy_console_call",
  "function" => "define_and_start"
}
virsh define failed at /usr/lib/os-autoinst/consoles/sshVirtsh.pm line 570, <$fh> line 28.

[2020-06-08T11:18:54.698 CEST] [debug] ||| finished bootloader_svirt installation at 2020-06-08 09:18:54 (20 s)

This issue is reproducible since Thursday 4/06/2020.
https://openqa.suse.de/tests/4322931#next_previous

History

#1 Updated by okurz over 1 year ago

  • Due date set to 2020-06-23
  • Category set to Support
  • Status changed from New to Feedback
  • Assignee set to okurz

the underlying problem seems to be

error: Failed to destroy domain openQA-SUT-2
error: internal error: Failed to destroy domain '817'

on the hypervisor host. I don't know what the reason for that could be but I suggest you look further in this direction.

Just to ensure a mutual understanding of expectations: According to https://progress.opensuse.org/projects/qa/wiki#Out-of-scope the maintainership of the additional worker hardware is out of scope for the QA tools team so it's unlikely we can be of great help.

#2 Updated by szarate over 1 year ago

I'm quite sure that the problem is somewhat related to this one: #67870

#3 Updated by okurz over 1 year ago

  • Status changed from Feedback to Resolved

No further response. I assume that with #67870 the problem is also gone for you. As there are no production-grade tests but just personally triggered ones I assume other tests are also not impacted.

Also available in: Atom PDF