Project

General

Profile

action #65954

Create a way to check which jobs contain a test

Added by ilausuch over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2020-04-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Using this url https://openqa.suse.de/admin/test_suites we could find a test.
And therefore in "All tests" page https://openqa.suse.de/tests page we could try to find this test in last finished jobs list.
But sometimes it doesn't appears because this list is limited to 500 jobs.
I could be interesting to get which jobs contain this test


Related issues

Is duplicate of openQA Project - action #34486: database of "test cases" or how to search for tests we have in openQAResolved2018-04-08

History

#1 Updated by geor over 1 year ago

I would really like to see this feature! It would help a lot with test design.
A feature that could also tie nicely to this one would be: being able to see the tests that contain a specific perl module.

#2 Updated by okurz over 1 year ago

  • Is duplicate of action #34486: database of "test cases" or how to search for tests we have in openQA added

#3 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

I am glad you came up with this. I see this ticket as a duplicate of the already existing feature request #34486 .

https://progress.opensuse.org/issues/34486?issue_count=3&issue_position=2&next_issue_id=29925&prev_issue_id=53402#Suggestion mentions some approaches that can already be taken by you and other users to find out which jobs contain a "test". Please be aware of the ambiguity of the word "test" here. http://open.qa/docs/#concepts has a complete definition within the openQA context.

Also available in: Atom PDF