Project

General

Profile

action #65130

Upgrade of firmware(s) for cloudberry (power9 machine)

Added by nicksinger over 1 year ago. Updated 5 months ago.

Status:
Rejected
Priority:
Low
Assignee:
Target version:
Start date:
2020-04-01
Due date:
% Done:

0%

Estimated time:

Description

Cloudberry is a new P9 machine we received. To make use of it I first need to upgrade its firmwares according to https://pes.nue.suse.com/Labs/Info_for_Labs/POWER_hardware/Firmware_update
This is to track this progress and make some notes about the process itself.


Related issues

Related to openQA Infrastructure - action #63142: Upgrade firmware of ppc9 machine redcurrantRejected2020-02-05

Related to openQA Infrastructure - action #58325: Update firmware of our powerKVM machines (QA-Power8-3, QA-Power8-4, QA-Power8-5)Rejected2019-10-17

History

#1 Updated by nicksinger over 1 year ago

  • Status changed from Workable to Feedback

Alright, yesterday I played around with the machine a little bit. I already downloaded the appropriate binaries from IBM. However, the guide recommends upgrading from within Linux. Therefore I created an LPAR with all resources attached (had to shutdown the VIOS for this). No I need to wait for infra to move the machine into the QA VLAN since machines in the ARCH network need to be managed by orthos now.

#2 Updated by nicksinger over 1 year ago

Infra traced down the cable and repluged the machine. However I'm still unable to connect to QA Net from within the LPAR. Another debugging session with Fatma is planned tomorrow at 14:00.

#3 Updated by nicksinger over 1 year ago

Unfortunately still no satisfying progress here. Last answer from infra:

Hi NIck

As per our last debugging session, port gi46 was setup to QA vlan12.
I still see no outcome for any mac address and the interface is down.
Can you check on the cloudberry side if the network interface is up ?
I have already triggered a no shutdown with no avail.
Unfortunately no one is in the office this week. Will seek to check physical
connection again once we have physical access.

On that account the only similar initial of the mac @ I have pulled out are the
following, if any of which are conencted to cloudberry other interfaces , let
me know.

571 98:be:94:4b:d3:97 Po1 dynamic
571 98:be:94:7c:01:27 Po1 dynamic
571 98:be:94:7c:01:72 gi12 dynamic
571 98:be:94:7c:02:9d gi31 dynamic
571 98:be:94:7c:2d:30 gi35 dynamic
571 98:be:94:7c:2d:63 gi33 dynamic
571 98:be:94:7c:2d:b1 gi34 dynamic
571 98:be:94:7c:59:5f gi11 dynamic
571 98:be:94:7c:59:6b gi10 dynamic
571 98:be:94:7c:59:d7 gi9 dynamic


570 98:be:94:7c:01:26 Po1 dynamic
570 98:be:94:7c:01:73 Po1 dynamic
570 98:be:94:7c:02:9c gi25 dynamic
570 98:be:94:7c:08:35 gi3 dynamic
570 98:be:94:7c:2d:31 gi5 dynamic
570 98:be:94:7c:2d:62 gi27 dynamic
570 98:be:94:7c:2d:b0 gi28 dynamic
570 98:be:94:7c:59:5e gi4 dynamic
570 98:be:94:7c:59:6a gi2 dynamic
570 98:be:94:7c:59:d6 gi1 dynamic

12 98:be:94:01:49:ec Po1 dynamic
12 98:be:94:0b:70:f8 gi24 dynamic
12 98:be:94:4b:d3:96 Po1 dynamic

11 98:4f:ee:0c:be:d9 Po1 dynamic
11 98:be:94:0b:ca:e8 gi37 dynamic
11 98:be:94:0b:ce:d4 gi21 dynamic
11 98:be:94:0c:87:30 gi15 dynamic
11 98:be:94:0c:94:d8 gi16 dynamic
11 98:be:94:68:6c:fb gi45 dynamic
11 98:be:94:7c:08:34 Po1 dynamic
11 98:be:94:f8:53:80 Po1 dynamic
11 98:be:94:f8:53:85 Po1 dynamic
11 98:be:94:f8:60:78 Po1 dynamic
11 98:be:94:f8:60:7d Po1 dynamic

However I can still not ping anything inside the QA network. I can only do a "ping check" inside the SMS and can't really help debugging this further. Haven't checked if one of the mentioned MACs maybe also belongs to cloudberry.

#4 Updated by cdywan over 1 year ago

  • Priority changed from High to Normal

#5 Updated by okurz over 1 year ago

Hi, I think we have other power9 machines (in the meantime) so likely this issue here is not "High" prio anymore. At least I have not seen or received any questions or push from stakeholders that we would need this with high prio. Also as there has been no update since a month we are reducing prio now to meet our SLO for "High" tickets.

#6 Updated by okurz about 1 year ago

  • Priority changed from Normal to Low

#7 Updated by cdywan about 1 year ago

nicksinger Any update on this?

#8 Updated by nicksinger about 1 year ago

Unfortunately not, last time I checked the machine was still not visible for qanet to hand out PXE entries. Maybe a problem with assigning all resources to a Linux LPAR (I doubt this but it's certainly possible) or still a problem on the network side. Who every feels for a challenge can just take this ticket and play around. Nothing you can really break

#9 Updated by okurz about 1 year ago

  • Status changed from Feedback to Workable
  • Target version set to Ready

If I understand correctly this is hardware that is currently still not usable for openQA, hence adding it to the backlog. However as you stated and if I understand correctly there is work to be done although first some investigation is necessary, hence adding back to "Workable" (could be "New" though some work has been done even though it is not exactly clear what is to be done)

#10 Updated by okurz 12 months ago

  • Related to action #63142: Upgrade firmware of ppc9 machine redcurrant added

#12 Updated by okurz 12 months ago

During qam-qasle-collaboration weekly it was suggested to talk to "Antonio Eisner"

#13 Updated by okurz 11 months ago

  • Status changed from Workable to Blocked
  • Assignee changed from nicksinger to okurz

#14 Updated by okurz 5 months ago

  • Status changed from Blocked to Feedback
  • Assignee changed from okurz to nicksinger

ticket was resolved with https://infra.nue.suse.com/SelfService/Display.html?id=179589#txn-2795688 . nicksinger can you help me with the current status as I know that you still have been involved in the area lately?

#15 Updated by okurz 5 months ago

  • Related to action #58325: Update firmware of our powerKVM machines (QA-Power8-3, QA-Power8-4, QA-Power8-5) added

#17 Updated by okurz 5 months ago

  • Status changed from Feedback to Rejected

As discussed with nsinger we are not aware of further problems after we fixed the boot problems software side in #68053 so we can also close this ticket as rejected as we did not conduct the firmware upgrades.

Also available in: Atom PDF