Project

General

Profile

action #64761

[functional][y] wicked changed behavior to reload instead of restart on latest version

Added by asmorodskyi over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
SUSE QA - Milestone 33
Start date:
2020-03-24
Due date:
2020-04-21
% Done:

0%

Estimated time:
3.00 h
Difficulty:

Description

After discussing with developers ( wicked and YaST ) https://bugzilla.suse.com/show_bug.cgi?id=1165923 it appears that it actually expected behavior to reload wicked instead of restart . Test behavior should be aligned accordingly

As of now we check logs to validate the behavior, so verify_network_configuration method to detect reload.
Log level for wicked is increased, so it's only matter of finding it.

Acceptance criteria

  1. Network devices reload is assured for the case when we rename device
  2. Behavior for SLE 15 SP1 and older is not affected

History

#1 Updated by riafarov over 1 year ago

  • Due date set to 2020-04-07
  • Category set to Enhancement to existing tests
  • Target version set to Milestone 33

#2 Updated by riafarov over 1 year ago

  • Due date changed from 2020-04-07 to 2020-04-21

#3 Updated by asmorodskyi over 1 year ago

From #wicked channel in RC :

@asmorodskyi: Marius Tomaschewski regarding yesterday bug , looks like this reload instead of restart behavior was introduced only recently , right ? is it something new introduced only in SLE 15 SP2 ? Latest updates in SLE 15 SP1 still keep doing restart https://openqa.suse.de/tests/4005300#step/yast2_lan_restart/106
@teclator: Yep, it was introduced recently in YaST (SLE-15-SP2) and mainly because we have rewritten yast-network. We used to set a force_restart flag that was not set after the rewrite, and that is why the behavior changed.

#4 Updated by riafarov over 1 year ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 3.00 h

#5 Updated by ybonatakis over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to ybonatakis

#7 Updated by ybonatakis over 1 year ago

the lib/y2lan_restart_common.pm has been modified to adapt the new changes in network service status and a new checking flow applied. So now according to the expectation we check if the filter will match with the context of journal.log.

#8 Updated by ybonatakis over 1 year ago

  • Status changed from In Progress to Feedback

#9 Updated by riafarov over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF