Project

General

Profile

action #63460

serial console stopped working on hyperv

Added by syrianidou_sofia over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-02-14
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

I cannot find a single hyperv test that does not fail.

Looks like the tests fail either on bootloader_start with error like :

SHA256 checksum does not match for ISO:
Calculated:
Expected: aac524d3a46967c89bb8d8761bc6e9f2986b40bc1a1ae60abc746dff01b001ee

or after first boot, while running commands that time out.

Test suite | Failed module
skip_registration@svirt-hyperv : integration_services [1]
skip_registration@svirt-hyperv-uefi : bootloader_start
lvm+RAID1@svirt-hyperv(/uefi) : validate_lvm_raid1 [2]
mediacheck@svirt-hyperv(/uefi) : bootloader_hyperv
minimal+base_yast@svirt-hyperv : system_prepare [3]
minimal+base_yast@svirt-hyperv-uefi : first_boot [4]

[1] Test died: command 'curl -f -v http://10.160.0.147:20103/V0WsZ7j56nMjfBev/current_script > /tmp/scriptHwmlo.sh' timed out at /usr/lib/os-autoinst/distribution.pm line 260.
[2] Test died: script timeout: lvscan | awk '{print $2}' | sed s/\'//g at /usr/lib/os-autoinst/testapi.pm line 1104.
[3] Test died: command 'chown bernhard /dev/ttyS0 && usermod -a -G tty,dialout,$(stat -c %G /dev/ttyS0) bernhard' timed out at /var/lib/openqa/cache/openqa.suse.de/tests/sle/lib/utils.pm line 1185.
[4] Test died: no candidate needle with tag(s) 'linux-login, emergency-shell, emergency-mode' matched (<--- looks like system hang on grub menu)

Example:

Observation

openQA test in scenario sle-15-SP2-Online-x86_64-lvm+RAID1@svirt-hyperv fails in
validate_lvm_raid1

Test suite description

Maintainer: slindomansilla, jrauch

Combination of LVM and RAID1, installation of RAID1 on top of LVM using expert partitioner.

(crypt-)LVM installations can take longer, especially on non-x86_64 architectures.

Reproducible

Fails since (at least) Build 139.1

Expected result

Last good: 136.2 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by syrianidou_sofia over 1 year ago

  • Subject changed from hyperv tests fail in different modules for latest build. to [functional][y] hyperv tests fail in different modules for latest build.

#2 Updated by syrianidou_sofia over 1 year ago

Looks like bootloader issues are separate matter. There is already an open ticket for this:
https://progress.opensuse.org/issues/57206

#3 Updated by riafarov over 1 year ago

  • Subject changed from [functional][y] hyperv tests fail in different modules for latest build. to serial console stopped working on hyperv

I can see that serial console stopped working completely there. Asking tools team to take a look.
So for the latest build, we don't get anything on serial during the runs. Worked somehow for full medium though: https://openqa.suse.de/tests/3893710

Looks sporadic.

Please, suggest how to proceed.

#4 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

https://openqa.suse.de/tests/3964102#previous looks pretty stable to me. No one in tools team has any experience with hyperv, in doubt, please ask [virtualization], e.g. xlai . rejecting as I assume you also don't want to do anything for this anymore after latest job shows up stable.

Also available in: Atom PDF