Project

General

Profile

action #62756

openqa-clone-job downloads images very slowly

Added by dancermak almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Support
Target version:
-
Start date:
2020-01-29
Due date:
2020-02-18
% Done:

0%

Estimated time:
Difficulty:

Description

When using openqa-clone-job to clone a job from o3 to a local instance, I frequently have to download the Tumbleweed iso and hdd image. Unfortunately, openqa-clone-job is very slow when downloading iso/qcow2 files, the download speed barely reaches 1 MB/s, while when downloading the same file via Firefox, my download speed reaches 10 MB/s.

If there is some throttling, could it be turned off?

History

#1 Updated by mkittler almost 2 years ago

There's no intentional throttling. Not sure why it is so slow in your case. I can usually get rates > MiB/s with openqa-clone-job. Note that openqa-clone-job uses internally LWP::UserAgent to do the download so if there's something wrong with the download the problem is likely caused by that Perl module.

#2 Updated by okurz almost 2 years ago

  • Category set to Support
  • Status changed from New to Feedback
  • Assignee set to okurz

This could depend on multiple factors why it is slow for you. Is this to a machine within SUSE nbg network or elsewhere?

#3 Updated by dancermak almost 2 years ago

okurz wrote:

This could depend on multiple factors why it is slow for you. Is this to a machine within SUSE nbg network or elsewhere?

It is elsewhere, but geographically relatively close.

#4 Updated by okurz almost 2 years ago

dancermak wrote:

okurz wrote:

This could depend on multiple factors why it is slow for you. Is this to a machine within SUSE nbg network or elsewhere?

It is elsewhere, but geographically relatively close.

yeah well, it must be "logically" close in the network to matter :) So, how else can we help you?

#5 Updated by dancermak almost 2 years ago

okurz wrote:

yeah well, it must be "logically" close in the network to matter :) So, how else can we help you?

Well, how can I debug the slowness of the download script? Because Firefox downloads at nearly full network speed.

#6 Updated by okurz almost 2 years ago

try to create a small reproducer script, e.g. strip out the relevant part from the perl script. Or try with "curl" on the console if it is as fast as firefox or as slow as clone-job.

#7 Updated by okurz almost 2 years ago

  • Due date set to 2020-02-18

#8 Updated by okurz almost 2 years ago

  • Status changed from Feedback to Resolved

no response.

#9 Updated by kraih almost 2 years ago

I've actually encountered this too on the staging machines a few months ago and it turned out to be a network problem then.

Also available in: Atom PDF