Project

General

Profile

action #6258

repo-checker: need a way to accept new edges

Added by dimstar over 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
2015-02-12
Due date:
% Done:

0%

Estimated time:

Description

Currently, the repo checker detects new cycles and adds new reviews, with no way for the factory maintainers to consciously accept those new cycles.

We need to come up with a solution to be able to accept those new cycles (current Staging:B)

History

#1 Updated by dimstar over 7 years ago

  • Assignee set to aplanas

#2 Updated by aplanas over 7 years ago

  • Status changed from New to Rejected

#3 Updated by coolo over 7 years ago

  • Status changed from Rejected to New

the issue is kind of wrongly formulated: we don't want to accept new edges, but new verteces aka packages into the cycle. Not by default, but the factory maintainer needs a way to guide the repo checker to approve certain new packages.

IMO this case is so seldom (hopefully) that it's acceptable to provide a meaningful way to patch the code temporarly to generate that whitelist.

#4 Updated by coolo almost 7 years ago

  • Status changed from New to Rejected

let's close this - it's way too complex for small edge cases

Also available in: Atom PDF