Project

General

Profile

action #62276

[SLE][Migration][SLE15SP2]test fails in yast2_migration - no candidate needle with tag(s) 'displaymanager' matched

Added by coolgw almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-01-19
Due date:
% Done:

0%

Estimated time:
12.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 fails in
yast2_migration

rerun and can be reproduce on Build126.1

Test suite description

basesys+srv all p1/c/y

Reproducible

Fails since (at least) Build 83.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by tinawang123 almost 3 years ago

  • Subject changed from [SLE][Migration][SLE15SP2]test fails in yast2_migration to [SLE][Migration][SLE15SP2]test fails in yast2_migration - no candidate needle with tag(s) 'displaymanager' matched

#2 Updated by leli almost 3 years ago

  • Estimated time set to 12.00 h

#3 Updated by coolgw almost 3 years ago

  • Assignee set to coolgw

#4 Updated by coolgw almost 3 years ago

linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3813013: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3813013
linux-4360:~/openqa-distr #

#5 Updated by coolgw almost 3 years ago

linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3813036: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3813036
linux-4360:~/openqa-distr #

#6 Updated by coolgw almost 3 years ago

Rerun it since above run failed before my fix!
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3813057: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3813057
linux-4360:~/openqa-distr #

#7 Updated by coolgw almost 3 years ago

above run show another kind of failed :(
try rerun it:

linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3813276: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3813276
linux-4360:~/openqa-distr #

#8 Updated by coolgw almost 3 years ago

this issue seems also related with following issue:
https://progress.opensuse.org/issues/46190

#9 Updated by coolgw almost 3 years ago

add wait still screen and rerun it
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3816313: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3816313
linux-4360:~/openqa-distr #

linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3816322: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3816322
linux-4360:~/openqa-distr #

#10 Updated by coolgw almost 3 years ago

linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3816337: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3816337
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3816338: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3816338
linux-4360:~/openqa-distr #

#11 Updated by okurz almost 3 years ago

Please see my comment in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9403#pullrequestreview-346391192 . As a generic remark: Add unconditional sleeps longer than 1 second is never a good idea and unfortunately I am growing a bit reluctant to see this coming up as a suggestion repeatedly. I know it is not obvious to see but as a suggestion in general: Please check failing tests step by step not only at the failed test step but also earlier ones. My expectation when implementing the "Investigation" tab was also that it helps especially to find out potential causes of failures. The failing scenario unfortunately can not find any "last good" as it is so unstable. In this case you just have to check what was changed since the last time a test worked. In this case instead I see the problem in https://openqa.suse.de/tests/3808820#step/yast2_migration/86 , which is matching on a new needle that is wrong as it matches falsely "displaymanager" when there is a password prompt.

#12 Updated by coolgw almost 3 years ago

try further debug:
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/debug http://openqa.suse.de/tests/3808820
Created job #3817016: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3817016

#13 Updated by coolgw almost 3 years ago

linux-4360:~ # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/debug http://openqa.suse.de/tests/3808820
Created job #3820590: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3820590
linux-4360:~ # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/debug http://openqa.suse.de/tests/3808820
Created job #3820591: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3820591
linux-4360:~ #

#14 Updated by coolgw almost 3 years ago

delete workround for 1102563
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3820723: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3820723
linux-4360:~/openqa-distr # git push -f upstream displaymanager
C
linux-4360:~/openqa-distr # /usr/local/bin/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/displaymanager http://openqa.suse.de/tests/3808820
Created job #3820724: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-Build126.1-online_sles15sp1_pscc_basesys-srv_all_full_y@aarch64 -> http://openqa.suse.de/t3820724
linux-4360:~/openqa-distr #

#15 Updated by coolgw almost 3 years ago

Just check latest build 133.1 and 134.1 the issue not happen, but my fix not merged yet.
https://openqa.nue.suse.com/tests/3848512
https://openqa.nue.suse.com/tests/3853617

#16 Updated by coolgw almost 3 years ago

  • Status changed from New to Resolved

Put PR here, but now seems issue not happen. so i put issue to resolve state, once this issue happen again then we reopen it to check it.
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9403

#17 Updated by okurz almost 3 years ago

  • Status changed from Resolved to Feedback

#18 Updated by okurz almost 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: online_sles15_pscc_basesys-srv-wsm_all_full_y
https://openqa.suse.de/tests/3920223

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#19 Updated by coolgw over 2 years ago

  • Status changed from Feedback to Resolved

http://openqa.suse.de/tests/3983983#next_previous
if you check history:
153.7 154.1 155.1
not exist problem, so i close it firstly

Also available in: Atom PDF