Project

General

Profile

action #60254

check module src code through openqa webui link not consistent with the real running code when using openqa-clone-custom-git-refspec

Added by coolgw about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2019-11-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

1) run openqa job using openqa-clone-custom-git-refspec such as:
openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/test http://openqa.suse.de/tests/3598332
Created job #3631946: sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-ppc64le-Build89.1-online_sles15_pscc_basesys-srv-phub_all_full_y@ppc64le -> http://openqa.suse.de/t3631946

The source code of first module isosize.pm is changed by my branch like following
# Maintainer: Alberto Planas aplanas@suse.com
diag($result_text);
record_info('isosize', $result_text, result => $result);

  • record_info('isosize', $result_text, result => $result);
  • record_info('isosize', $result_text, result => $result);

2) check the cloned job t3631946, click the web ui link check source code of isosize.pm through UI link: https://openqa.suse.de/tests/3631946/modules/isosize/steps/1/src, the result is not consistent with the real running code, i mean it should show the branch code changed by me.


Related issues

Related to openQA Project - action #59184: Research about testing with a custom git refResolved2019-11-07

Is duplicate of openQA Project - action #54965: Cannot inspect the source code of the tests from my forkResolved2019-08-01

History

#1 Updated by coolo about 2 years ago

  • Related to action #59184: Research about testing with a custom git ref added

#2 Updated by coolo about 2 years ago

  • Category set to Feature requests

#3 Updated by okurz about 2 years ago

  • Is duplicate of action #54965: Cannot inspect the source code of the tests from my fork added

#4 Updated by okurz about 2 years ago

  • Status changed from New to Rejected
  • Assignee set to okurz

Also available in: Atom PDF