action #60140

job incompletes failing on initial asset download with "Asset was already requested by another job"

Added by okurz 3 months ago. Updated about 1 month ago.

Status:ResolvedStart date:28/01/2019
Priority:NormalDue date:
Assignee:kraih% Done:

0%

Category:Concrete Bugs
Target version:Done
Difficulty:
Duration:

Description

Observation

In https://openqa.opensuse.org/tests/1091856/file/autoinst-log.txt we see

[2019-11-21T20:45:00.0507 CET] [debug] Downloading openSUSE_Krypton_Qt_5.14.x86_64-5.12.80-Build16.2.iso, request sent to Cache Service (148635)
[2019-11-21T20:45:05.0571 CET] [debug] Download of openSUSE_Krypton_Qt_5.14.x86_64-5.12.80-Build16.2.iso processed: Asset was already requested by another job
[2019-11-21T20:45:05.0601 CET] [info] +++ worker notes +++
[2019-11-21T20:45:05.0601 CET] [info] End time: 2019-11-21 19:45:05
[2019-11-21T20:45:05.0601 CET] [info] Result: setup failure

this could be a regression from https://github.com/os-autoinst/openQA/pull/2463 solely based on that I did not see this problem in before and the PR was just recently merged.

Created this specific ticket for easier tracking with a more distinct subject line.


Related issues

Related to openQA Project - action #60626: "Download .* processed" but ending up with setup-failure,... Resolved 04/12/2019 11/12/2019
Copied from openQA Project - action #46742: test incompletes trying to revert to qemu snapshot auto_r... Feedback 28/01/2019 18/02/2020

History

#1 Updated by okurz 3 months ago

  • Copied from action #46742: test incompletes trying to revert to qemu snapshot auto_review:"Could not open backing file: Could not open .*.qcow.*No such file or directory", likely premature deletion of files from cache added

#2 Updated by coolo 3 months ago

  • Assignee set to kraih
  • Target version set to Current Sprint

That clearly shouldn't be an error

#3 Updated by coolo 3 months ago

I picked it into CS under the assumption it's a regression - if it's not, feel free to move it to Ready

#4 Updated by kraih 3 months ago

Yes, Asset was already requested by another job is not an error. This is the case we earlier talked about in Rocket Chat. The reason for the download failure can only be found in the cacheservice-minion journal or the autoinst-log,txt of the other job that requested the download first. My recent cache service patches have changed nothing here, except for the phrasing of the log message.

#5 Updated by kraih 3 months ago

The answer was actually right in the next job in line. It was a 404 on the ISO. https://openqa.opensuse.org/tests/1091857/file/autoinst-log.txt

#6 Updated by kraih 3 months ago

I think i know how to show the full log for both jobs, but it might require quite a bit of work.

#7 Updated by kraih 3 months ago

  • Status changed from New to Workable

#8 Updated by okurz 3 months ago

  • Related to action #60626: "Download .* processed" but ending up with setup-failure, workers are missing updated perl-Mojolicious >= 8.24 added

#9 Updated by kraih 2 months ago

  • Status changed from Workable to Feedback

The pull request for shared cache service logs has been applied. This ticket should be resolved. https://github.com/os-autoinst/openQA/pull/2615

#10 Updated by okurz about 1 month ago

  • Status changed from Feedback to Resolved
  • Target version changed from Current Sprint to Done

No further fallout from deployment so we can call it done.

Also available in: Atom PDF