Project

General

Profile

Actions

action #59984

closed

unstable test: t/05-scheduler-full.t

Added by okurz over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2019-11-18
Due date:
% Done:

0%

Estimated time:


Related issues 2 (0 open2 closed)

Related to openQA Project - action #62015: jobs incomplete without logs as some workers are rejected (was: Scheduler does not work)Resolvedmkittler2020-01-10

Actions
Related to openQA Project - action #53498: [sporadic] openQA CI tests fail on master in flaky/unstable t/ui/26-jobs_restart.tResolvedokurz2019-06-24

Actions
Actions #1

Updated by okurz over 4 years ago

  • Status changed from In Progress to Feedback
Actions #2

Updated by livdywan over 4 years ago

    #   Failed test 'one job allocated'
    #   at t/05-scheduler-full.t line 132.
    #          got: '0'
    #     expected: '1'
    # Looks like you failed 1 test of 1.
t/05-scheduler-full.t .. 7/? 
#   Failed test 'Simulation of unstable workers'
#   at t/05-scheduler-full.t line 178.
Can't use an undefined value as a HASH reference at t/05-scheduler-full.t line 133.

Seems to me like the test is buggy. The error seems to refer to this:

is(@{$allocated}[0]->{job},    99982, 'right job allocated');
Actions #3

Updated by okurz over 4 years ago

  • Related to action #62015: jobs incomplete without logs as some workers are rejected (was: Scheduler does not work) added
Actions #4

Updated by okurz about 4 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (okurz)
  • Target version changed from Current Sprint to Ready

So https://github.com/os-autoinst/openQA/pull/2516 is merged. I did not invest further time in making tests more stable here but there is also the related #53498

Actions #5

Updated by okurz about 4 years ago

  • Related to action #53498: [sporadic] openQA CI tests fail on master in flaky/unstable t/ui/26-jobs_restart.t added
Actions #6

Updated by okurz about 4 years ago

  • Status changed from Workable to Feedback
  • Assignee set to okurz
Actions #7

Updated by okurz about 4 years ago

  • Status changed from Feedback to Resolved

The above and also latest commit from mkittler ae1b7450a seemed to have helped. As our list of "unstable" tests is currently empty but tests seem to be stable I regard this as resolved.

Actions

Also available in: Atom PDF