Project

General

Profile

tickets #59942

IRC bot does not sent monitoring notifications any longer

Added by lrupp almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
IRC and Matrix
Target version:
-
Start date:
2019-07-03
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

The current IRC bot on #opensuse-admin@irc.opensuse.org does not forward notifications from the monitoring any longer.

Looks like an issue with the "latest" switch form Python2 to Python3.

=> needs investigation


Subtasks

tickets #53819: IRC bot: monitoring notifications brokenClosed

History

#1 Updated by lrupp almost 2 years ago

  • Private changed from Yes to No

#2 Updated by lrupp almost 2 years ago

  • % Done changed from 0 to 40

First: the old Supybot package was replaced by python3-limnoria and python2-limnoria packages. I deleted the python2-limnoria now, so that there is clearly only Python 3 involved.

The additional plugin, supybot-notify, was already ported to Python 3 via python-modernize.

Observations: The plugin is loaded and also starts the local listener on port 5050 - but messages to this port do not get delivered to the channel. As the rest of the Limnoria bot works, I currently expect the problem inside the plugins code base => analyzing.

#3 Updated by lrupp almost 2 years ago

  • Status changed from New to In Progress

#4 Updated by cboltz almost 2 years ago

FYI: I did some of these changes to get the bot running again after the Leap upgrade, and also noticed that the monitoring notifications were broken. See #53819 for some details.

#5 Updated by lrupp almost 2 years ago

cboltz wrote:

FYI: I did some of these changes to get the bot running again after the Leap upgrade, and also noticed that the monitoring notifications were broken. See #53819 for some details.

Thanks for the information.
I think we need to adjust your patch (six.moves.socketserver => socketserver), but this is not the real cause of the problem. The Socket Server (any of the two socket servers) starts, but seems to be unable to forward incoming requests to the application. There seems to be some changes in the new Limnoria, which are not backward compatible...

#6 Updated by lrupp over 1 year ago

  • Status changed from In Progress to Closed

lrupp wrote:

I think we need to adjust your patch (six.moves.socketserver => socketserver), but this is not the real cause of the problem. The Socket Server (any of the two socket servers) starts, but seems to be unable to forward incoming requests to the application. There seems to be some changes in the new Limnoria, which are not backward compatible...

Debugged the root cause: in python3 'split' expects the line to be byte, not string. Enforcing this and decoding the results after the split did the trick.

=> python3 patch enhanced, package updated in network and openSUSE:infrastructure.

New package deployed on the monitoring server. Initial testing done - assuming that our monitoring should also work with this -> closing.

Also available in: Atom PDF