action #59867

[functional][u] New plasma_browser_integration test is unstable

Added by dimstar 3 months ago. Updated 27 days ago.

Status:ResolvedStart date:15/11/2019
Priority:NormalDue date:
Assignee:zluo% Done:

100%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde-live-wayland@64bit_virtio-2G fails in
plasma_browser_integration

This newly added test module seems a bit unreliable at this moment

Test suite description

Like kde-live, but switches to a wayland session. riafarov: I've increased RAM to 2048

Reproducible

Fails since (at least) Build 20191113

Expected result

Last good: 20191112 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #60236: [functional][u] test fails in plasma_browser_integration ... New 25/11/2019

History

#1 Updated by favogt 3 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

kde-live-wayland has 3G RAM now and the assert_screen for the installation button a longer timeout: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8930

#3 Updated by mgriessmeier 2 months ago

  • Subject changed from New plasma_browser_integration test is unstable to [functional][u] New plasma_browser_integration test is unstable

#4 Updated by mgriessmeier 2 months ago

  • Related to action #60236: [functional][u] test fails in plasma_browser_integration on aarch64 added

#5 Updated by zluo about 1 month ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and check

#6 Updated by zluo about 1 month ago

opensuse-Tumbleweed-KDE-Live-x86_64-Build20200115-kde-live-wayland@64bit_virtio-3G can be found atm. opensuse-Tumbleweed-KDE-Live-x86_64-kde-live-wayland@64bit_virtio-2G is not available on o3 atm. I think this issue might be related to RAM size.

#7 Updated by zluo about 1 month ago

QEMURAM is 2048, so this is same!

#8 Updated by zluo about 1 month ago

checking opensuse-Tumbleweed-DVD-x86_64-Build20200115-kde-wayland@64bit_virtio uses QEMURAM=1536

#9 Updated by zluo about 1 month ago

for more than 80 test runs I have only 1 failure: http://f40.suse.de/tests/6352#step/plasma_browser_integration/42

So this is sporadic issue to me. And QEMURAM=1536 is used!

#10 Updated by zluo about 1 month ago

failed because plasma-browser-integration-install is not matching because firefox is still waiting for google-analytics.com:

http://f40.suse.de/tests/6408#step/plasma_browser_integration/31

90 timeout seems to be not enough.

#11 Updated by zluo about 1 month ago

https://openqa.opensuse.org/tests/1146534#step/updates_packagekit_kde/15 shows at moment needle match issue. fix this at first and try with my PR later.

#13 Updated by zluo about 1 month ago

#15 Updated by zluo about 1 month ago

https://openqa.opensuse.org/tests/1150645 : needle issues got fixed now.

#16 Updated by zluo about 1 month ago

#18 Updated by zluo about 1 month ago

to check https://openqa.opensuse.org/tests/1151664 which runs with my PR.

#20 Updated by zluo 27 days ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF