Project

General

Profile

action #59843

[spvm][kernel][openqa] test fails in coredump_collect - multiple select_console fails

Added by pcervinka almost 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Spike/Research
Target version:
QE Kernel - QE Kernel Done
Start date:
2019-11-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
medium

Description

Observation

openQA test in scenario sle-15-SP2-Installer-DVD-ppc64le-extra_tests_kernel_spvm@ppc64le-spvm fails in
coredump_collect

Test suite description

Maintainer: pcervinka

Reproducible

Fails since (at least) Build 89.1 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

If there is select_console root-console used in separate test modules, it will fail. Not an issue if single module is used(like it was till now).
It is probably related that select_console automatically re-selects root-ssh console during execution.


Related issues

Related to openQA Tests - action #60497: [sle][functional][u]test fails in keymap_or_locale - root-console not matchedResolved2019-12-02

History

#2 Updated by pcervinka almost 2 years ago

  • Status changed from New to In Progress

#3 Updated by pcervinka almost 2 years ago

Issue seems to be on testapi.pm in os autoinst in select_console function:

    my $ret = query_isotovideo('backend_select_console', {testapi_console => $testapi_console});
    die $ret->{error} if $ret->{error};

    $autotest::selected_console = $testapi_console;
    if ($ret->{activated}) {
        # we need to store the activated consoles for rollback
        if ($autotest::last_milestone) {
            push(@{$autotest::last_milestone->{activated_consoles}}, $testapi_console);
        }
        $testapi::distri->activate_console($testapi_console, @args);
    }

When is select_console root-console called first time, result of isotovideo query contains activated and and activate_console is called.
Function activate_console is in distri lib/susedistribution.pm. I contains check for spvm backend(and others) and returns use_ssh_serial_console, which works as expected. Proper root-ssh console is selected.

 # Select configure serial and redirect to root-ssh instead
    return use_ssh_serial_console if (get_var('BACKEND', '') =~ /ikvm|ipmi|spvm/ && $console =~ m/root-console$|install-shell|log-console/);

When is select_console called second time, result of isotovideo query doesn't contain activated, there is no call to activate_console and test fails, as it expects standard console needle.

#4 Updated by pcervinka almost 2 years ago

Did a quick idea to disable check in select_console and run activate_console all the time. It partially works on spvm http://10.100.12.105/tests/3684, but it definitely breaks something else.

#5 Updated by pcervinka over 1 year ago

  • Status changed from In Progress to Workable

#6 Updated by pcervinka over 1 year ago

  • Status changed from Workable to In Progress

#7 Updated by pcervinka over 1 year ago

  • Related to action #60497: [sle][functional][u]test fails in keymap_or_locale - root-console not matched added

#9 Updated by pcervinka over 1 year ago

  • Status changed from In Progress to Feedback

Lets result of next build

#10 Updated by pcervinka over 1 year ago

  • Status changed from Feedback to Resolved

Restarted job looks good: https://openqa.suse.de/tests/3926668

#11 Updated by metan over 1 year ago

  • Target version changed from 445 to 457

#12 Updated by pcervinka about 1 year ago

  • Target version changed from 457 to QE Kernel Done

Also available in: Atom PDF