Project

General

Profile

action #59339

[functional] Support Server based on SLE12-SP3 is broken

Added by jlausuch almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-11-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Support Server fails to install NFS related packages in ARM.
https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/support_server/setup.pm#L530

Test suite description

Maintainer: Pavel Sladek psladek@suse.com
according to https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/tests/support_server/setup.pm#L35

Reproducible

Fails since (at least) Build 0372

# zypper -n in rpcbind nfs-kernel-server | cat; ( exit ${PIPESTATUS[0]} ); echo yjD1U-$?-
File '/content' not found on medium 'http://download.suse.de/install/SLP/SLE-12-SP3-Server-GM/x86_64/DVD1/'

Expected result

Last good: 0369

# zypper -n in rpcbind nfs-kernel-server | cat; ( exit ${PIPESTATUS[0]} ); echo yjD1U-$?-
Loading repository data...
Reading installed packages...
'rpcbind' is already installed.
Package 'rpcbind' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
'nfs-kernel-server' is already installed.
Package 'nfs-kernel-server' is not available in your repositories. Cannot reinstall, upgrade, or downgrade.
Resolving package dependencies...
Nothing to do.

Further details

The tests are using the same qcow2 image since a bunch of builds, and the reason why it got broken recently is because
http://download.suse.de/install/SLP/SLE-12-SP3-Server-GM/x86_64/DVD1 does not longer exist.

We should build a new support server image using a newer repo. E.g. SP4:
http://download.suse.de/install/SLP/SLE-12-SP4-Server-GM/x86_64/DVD1

History

#1 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: hpc_BETA_mvapich2_mpi_supportserver
https://openqa.suse.de/tests/3583201

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#2 Updated by jlausuch over 1 year ago

sebchlad you are using support server. If you feel this ticket is still valid let me know. Otherwise I will close it.

#3 Updated by sebchlad over 1 year ago

For NFS I'm using one of the HPC nodes and not support server, so sure, you can go ahead and close this item.
Thx for following up!

#4 Updated by jlausuch over 1 year ago

  • Status changed from Workable to Closed

Also available in: Atom PDF