action #59267

test incompletes in installation_overview - when trying to switch to root-ssh?

Added by okurz 5 months ago. Updated 5 months ago.

Status:ResolvedStart date:10/11/2019
Priority:UrgentDue date:
Assignee:coolo% Done:

0%

Category:Concrete Bugs
Target version:Current Sprint
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-QR-x86_64-btrfs@64bit-ipmi fails in
installation_overview in

[2019-11-10T00:26:18.598 CET] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/installation/installation_overview.pm:83 called testapi::select_console
[2019-11-10T00:26:18.598 CET] [debug] <<< testapi::select_console(testapi_console='root-ssh')
/usr/lib/os-autoinst/consoles/vnc_base.pm:58:{
  'port' => 37447,
  'ikvm' => 0,
  'hostname' => 'localhost'
}
[2019-11-10T00:26:19.721 CET] [debug] Connected to Xvnc - PID 16153
icewm PID is 16174
xterm PID is 16176
[2019-11-10T00:26:20.753 CET] [debug] Could not connect to root@fozzie-1.qa.suse.de, Retrying after some seconds...
[2019-11-10T00:26:30.754 CET] [debug] Could not connect to root@fozzie-1.qa.suse.de, Retrying after some seconds...
[2019-11-10T00:26:40.755 CET] [debug] Could not connect to root@fozzie-1.qa.suse.de, Retrying after some seconds...
[2019-11-10T00:26:50.756 CET] [debug] Could not connect to root@fozzie-1.qa.suse.de, Retrying after some seconds...
[2019-11-10T00:27:00.757 CET] [debug] Could not connect to root@fozzie-1.qa.suse.de, Retrying after some seconds...
[2019-11-10T00:27:10.762 CET] [debug] Backend process died, backend errors are reported below in the following lines:
Error connecting to <root@fozzie-1.qa.suse.de>: Connection refused
[2019-11-10T00:27:10.806 CET] [debug] IPMI: Chassis Power Control: Down/Off
…

Test suite description

Maintainers: QSF-y.

Test installation with btrfs filesystem. Performs installation only.

Reproducible

Fails since 6.4

Expected result

Last good: 6.2

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #59273: module result missing for incompleting job New 10/11/2019
Related to openQA Project - action #60416: "(undefined value as a symbol reference.*serial_screen|sv... Resolved 28/11/2019

History

#1 Updated by okurz 5 months ago

  • Related to action #59273: module result missing for incompleting job added

#2 Updated by coolo 5 months ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from [qam][qr] test incompletes in installation_overview - when trying to switch to root-ssh? to test incompletes in installation_overview - when trying to switch to root-ssh?
  • Category changed from Bugs in existing tests to Concrete Bugs
  • Target version set to Ready

That job should be failed and not incomplete. We can't ask reviewers to review incomplete jobs - incomplete mean setup failure, while here it's a problem in the test, so it should fail.

#3 Updated by coolo 5 months ago

  • Assignee set to coolo
  • Target version changed from Ready to Current Sprint

#4 Updated by coolo 5 months ago

  • Status changed from New to In Progress

#5 Updated by okurz 5 months ago

https://openqa.suse.de/tests/3581465#step/installation_overview/17 show the correct, expected behaviour in production on hotpatched openqaworker2: The job fails with a clear message instead of incomplete. @coolo I would consider this ticket fixed then as the PR is merged and we already showed the result in production. We can create a test specific ticket as followup

#6 Updated by coolo 5 months ago

  • Status changed from In Progress to Resolved

#7 Updated by okurz 4 months ago

  • Related to action #60416: "(undefined value as a symbol reference.*serial_screen|svirt serial: unable to read)" Better feedback for "The console .* is not responding (half-open socket?)", very big log files with repetition of log message added

Also available in: Atom PDF