Project

General

Profile

Actions

action #58748

closed

[qam] [packageinstallation] [sprint] test qam-incidentinstall fails in update_install since update introduces new package

Added by kgw_suse over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-10-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

test qam-incidentinstall for update S:M:12428:202971 (python-scp) fails in module update_install in scenarios

sle-12-SP4-*-DVD-Incidents-Install, any_architecture:

sle-12-SP3-Server-DVD-Incidents-Install, any_architecture:

Error message: Package 'python-applicationinsights' not found.

Reason: this package is new, introduced by the update under test.
Therefore the attempt to prepare for the update by installing the latest release
of this package fails as a matter of course.
The test appears to be unable to regard this situation as legitimate.

Test suite description

Installs all latest releases of the packages provided by an update under test, then installs the update under test.

Reproducible

Fails since (at least) Build :12428:python-scp (current job)

Expected result

Last good: :12554:python (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by kgw_suse over 4 years ago

  • Related to action #50471: [qam] [packageinstallation] qam-incidentinstall test fails in update_install if intentionally conflicting packages are covered by the incident added
Actions #2

Updated by kgw_suse over 4 years ago

  • Related to deleted (action #50471: [qam] [packageinstallation] qam-incidentinstall test fails in update_install if intentionally conflicting packages are covered by the incident )
Actions #4

Updated by tjyrinki_suse almost 4 years ago

  • Subject changed from [QAM] test qam-incidentinstall fails in update_install since update introduces new package to [qam] [packageinstallation] test qam-incidentinstall fails in update_install since update introduces new package
  • Status changed from New to Workable
Actions #5

Updated by apappas almost 4 years ago

  • Subject changed from [qam] [packageinstallation] test qam-incidentinstall fails in update_install since update introduces new package to [qam] [packageinstallation] [sprint] test qam-incidentinstall fails in update_install since update introduces new package
  • Status changed from Workable to In Progress

This should be completely resolved by this PR. Now the test not only doesn't fail on newly introduced binaries, but actually installs them.

Actions #6

Updated by apappas almost 4 years ago

  • Assignee set to apappas
Actions #7

Updated by apappas over 3 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF